• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Touch circuit sound, led. 555 timer

reading...what does it mean "fiddly"? and "starts working a 5v"?
Does that mean marginally?
Its his opinion. The pot is super tiny. One tiny adjustment make large jumps in the output. I have learned to work it. And I wear a pair of 4.0 readers so I can see the darn thing. If you prefer I can use one of thoes USB phone charger supplies.
 

eTech

Well-Known Member
OK...So lets start with the 4013.
You currently a have a n.o. push button connected as the input for testing right?

In this test we are trying to make the 4013 circuit fail by pressing the button once or multiple times.
To test the 4013:
1. Disable the timer by disconnecting pin 2 of 555 (this disconnects 555 trigger from 4013)
2. Connect your +probe to pin 13 and -probe to ground.
3. Remove power from circuit then re-apply power.
4. After power up...wait one minute. Pin 13 should be steady at 0v.
5. Press the button once. Pin 13 should immediately change to 5v and remain steady at 5v.
6. Press the button repeatedly and ensure the voltage at pin 13 toggles between +5 and 0v once each time you press the button. If it misses a toggle, or toggles multiple times with one button press, the circuit has failed and we have a problem.

Perform this test until confident the 4013 is toggling reliably.

Report back...
 
Last edited:
Connect your +probe to pin 13 and -probe to ground.
Press the button repeatedly and ensure the the voltage at pin 13 toggles between +5 and 0v (close to 0v) each time you press the button. If it misses a toggle, we have a problem.
Ok did this about 10 times allowing about 1.5 seconds between toggles to allow the voltage to register. It went from 5v to 0v .
Important to note it would not work the first 3 times. I let it be for 15 seconds then it worked continuelessly. Even pressing it rapidly it worked
 

eTech

Well-Known Member
Do have an extra cap we can use? About 470uf,16v minimum?

if so, connect it across output of dc-dc converter.

power up circuit, wait 1 minute, then try 4013 test again.
Report back.
 

eTech

Well-Known Member
No...connect it across the 5v supply output and the supply wires for the circuit. We want to add some supply ripple filtering. Pay close attention to the cap polarity markings! The cap will pop like a firecracker if you connect wrong. + cap connects to +5, - cap to ground.
 

eTech

Well-Known Member
Done. No change. Only timer led goes out. No beep, no relay opening. Going to pick up kids.
Remember...we’re focusing only on the 4013 part of the circuit. Perform the test in #42.
Report back. Don’t worry about the other parts of the circuit yet. :)

well resume when you are ready.
 
#49. Did I connect the cap correctly?
This is between the 12v supply, before the mini-360. Or would you want it right after the mini-360
 
Last edited:

eTech

Well-Known Member
I've modified post #42 to clarify the steps for testing the 4013 part of the circuit.
A new step is "disabling" the 555 timer to prevent impacting the test.
 
Perform the test in #42.
Report back. Don’t worry about the other parts of the circuit yet.
Ok. Test done with cap 470 16v inserted after mini-360.
This time it manually cycled on and off rapidly with no issues. It still does not auto cycle. Only the led goes out and the relay remains engaged. Voltage at pin 13 remains at 5v.
 
Press the button repeatedly and ensure the voltage at pin 13 toggles between +5 and 0v once each time you press the button. If it misses a toggle, or toggles multiple times with one button press, the circuit has failed and we have a problem.

Perform this test until confident the 4013 is toggling reliably.

Report back...
Ok. I believe this might have been happening previously but thought my jittery fingers were just double striking the button. This time I performed the test a little slower holding the button down for a moment before releasing. Now I can observe 4013 behaving more like a latch. Where down press engages the relay and up press disengaged the relay. This happens 80% of the time. Now it does not miss a toggle or double toggle.
 

eTech

Well-Known Member
Ok. I believe this might have been happening previously but thought my jittery fingers were just double striking the button. This time I performed the test a little slower holding the button down for a moment before releasing. Now I can observe 4013 behaving more like a latch. Where down press engages the relay and up press disengaged the relay. This happens 80% of the time. Now it does not miss a toggle or double toggle.
Yes...when you press the button down, a pulse is generated that causes the flip flop to "toggle" its state. So multiple "press then release" should generate a pulse on each "press" of the button.

So...disregarding the rest of the circuit, I take your comments to mean that the 4013 toggle is working to your satisfaction...correct? I think its working as intended.
 
Last edited:
Yes...when you press the button down, a pulse is generated that causes the flip flop to "toggle" its state. So multiple "press then release" should generate a pulse on each "press" of the button.

So...disregarding the rest of the circuit, I take your comments to mean that the 4013 toggle is working to your satisfaction...correct? I think its working as intended.
Oh so that's how its supposed to work. Yes. A latch on press, then when button is released it un-latches. Yes. Thats nice. Its not consistent though. Upon disconnecting and re connecting the power its less frequent now. 50% of the time it behaves like a latch the rest of the time its a pulse
 
I'm repeating myself to be sure were on the same page.
A latch completes a cycle of the relay closing and opening on one press and release of the button.
A pulse would require 2 separate button presses to do the same thing.
 

EE World Online Articles

Loading
Top