• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

FTDI Cable Transmitting Extra Gibberish Character

Status
Not open for further replies.

dknguyen

Well-Known Member
Most Helpful Member
For some reason, my USB to RS-422 cable started sending an extra gibberish character for every character that I transmit. This gibberish character is unique and repeatable to the particular character that I myself sent. This does not happen when receiving. This was tested by looping the cable's own transmission lines back onto it's receive lines.

I am not aware of a setting (nor did I change any setting) that would cause a whole additional character to be sent with every transmitted character. Is anyone able to provide any clues?
 

Attachments

rjenkinsgb

Well-Known Member
Most Helpful Member
It is a genuine FTDI device or one of the chinese clones?

Or, is there a possible problem with the driver - an auto update or corruption? I have seen problems on Windows systems with different driver versions.
 

dknguyen

Well-Known Member
Most Helpful Member
It is a genuine FTDI device or one of the chinese clones?

Or, is there a possible problem with the driver - an auto update or corruption? I have seen problems on Windows systems with different driver versions.
Genuine. I didn't run an auto-update and at least I'm not aware of one occurring...
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top