• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

USB drive issues - unrecognized (won't mount and fix)

KeepItSimpleStupid

Well-Known Member
Most Helpful Member
Thread starter #1
I purchased a USB stick of all the issues of a magazine.

Initially, I tried to mount it about 12x on my laptop running Linux moving the slider each time. Only two were successful. I moved the data to a NAS. The ASUS router runs Linux too. You can access the CLI and mount a USB drive for sharing. It was unsuccessful too.

Some things I had a my disposal:

The USB stick.

I had a USB extension cable

A public computer running win 7 enterprise at staples HP Touchsmart 9300 Elite Nickname (SPC)
A copier at Staples that has an Android interface (SCP)

An ASUS RT AC-68U router running linux with USB 2 and 3 ports. You can share USB disks (AR). I do have 3 with various firmwares.
A powered USB2 hub (AR+USB-Hub)

A Toshiba A665 Laptop running Ubuntu Linux (Tos-LT)
A 20' active cable that I tried on the laptop only (ET+Tos-LT)

Mechanically, the tab on the USB Stick is about 0.050" short compare to two USB cables. (extension and active).
It has a rounded shape. Standard USB does not.

The staples copier recognized the USB Stick

The Staples PC did not: with and without the extension cable.
There was a definite issue with the vault and mechanics on that machine. Port was recessed.
I did take a pic with my phone of the USB ports.

Revisited my laptop.
With extension cable - Not recognized
With an active cable (20 feet) - recognized.

Revisited the ASUS router
Initially, I used the USB3 port on the router yesterday - not recognized

I connected a USB2 4-port hub to the USB2 port on the router.
Initially VUSB Stick not recognized - No blue light on hub. (Possible contact issues)
then I immediately used the hub with extension cable to the USB Stick and direct from hub to the USB Stick and it was recognized.

Clearly, the manufacturer of the USB stick has an issue at least with the USB Stick I received.

Mechanically, the USB Stick doesn't seem to be connector compatible, but it looks like electrical issues as well.

A hub MIGHT make the USB Stick work on my laptop.

I was told indirectly by the OEM the USB stick which is unknown to me, that either works or doesn't goes out the window.

So, basically a HUB or an Active cable made the stick work!
 

EE World Online Articles

Loading

 
Top