Continue to Site

Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Phonic Firefy 808 Issues

Stef123

New Member
Hi,

sorry for not introducing myself first - i have a quite delicate Problem with my Phonic Firefly 808 Universal (Firewire/USB) from 2012, which i bought in non working condition and getting Schematics / Service Manuals for this thing, as well as for other devices based on the BridgeCo DM-Series (DM-Series was also utilized by Terratec, M-Audio etc, any Audio Interface which incoorporates Firewire)), looks very impossible -idk why, because this Platform and technology around it is quite outdated.

Well, it was said by the seller that it cannot be recogized by USB any longer, and a close inspection revealed that the D+Trace of the USB Port was "flying" around; no idea how that could happen. Means that i had to make a new connection, which i eventually did. But it looks like as the Firefly "resets" for each two seconds, because the Power light dims down for a short amount of time - before it does that again in a repeated loop.

Oscilloscope shows that the Voltage on the CPU PCB drops for a short period, but not on the serving Main PCB. So hooked up a logic analyzer to something "what seems to be a 4-Pin debug port" - no idea which Format it has, i suppose serial, and it outputs something, but repeatedly for each two seconds.

USB D+ and D- is low all the Time, even with a computer connected, which in conclusion cannot be right. They go straight into the Main DM1500 ASIC, which seems to boot a stripped down Linux Kernel from Flash. Of course there is also no Datasheet of that ASIC anywhere available, because the Company, which bought BridgeCo around a decade ago, closed Business at the very beginning of 2023.

So the question is: Whats happening here. As for my own experience of programming Microcontrollers for +30 Years, it -might- be possible that the integrated USB port of the ASIC changes State from unconfigured to something that does not "quite" like 3.3 / 5 Volts being pulled directly to GND in case of a defect, but i assume that should happen right after power up. And the ASIC itself won´t get hot at all, but seems to run (otherwise i wouldnt get "debug data" out of it, in whatever format it is). A diode Test revels at least no short curcuit between GND and the USB D-Pins.

Any help - and probaly someone which can share additional information about that specific Platform, at best a Service Manual for the Firefly, is very welcome!

Best regards!
 
If the power supply is OK at one point but not another, the first thing I'd is check through any connectors, decoupling caps or regulators etc., to get that stable - it could be that as the unit initialises, the load increases and causes a low voltage reset?

Nice looking using - it reminds me of a Tascam setup I had, similar age or slightly older.
 
That thing was quite cheap - and should replace my ST Audio ADC/DAC2000, because the ST is much older and uses an old fashion PCI card, so the choice of PCs is naturally limited - back in the old days i had four of them "chained" (all in all 32 I/O-Channels) together in one Computer.

Ok, for todays standard that Phonic-thing is also quite old, but it still has some useful specs.

Indeed, i also think that something pulls too much power, maybe something that "opens" the Audio Channels (you know, the same thing as the relays in certain Amps) . What makes me nervous is the USB-Issue. Why was the D+wire flying around - i mean, that doesn´t happen by itself - and it wasn´t burnt away. Because -if- there is really an USB Issue, any further effort would be senseless.

If i would my get hands onto the schematics, i could power the CPU PCB externally and see how far it goes from there. This is something i should do first.
 
Sure. For the moment the CPU PCB only. Explanation: If this board is powered externally with 5V by a PC PSU, it seems to stable while it comsumes around 200mA, but still no USB.

If it is powered by an 1 Amp Buck DC-DC-Converter, it starts to do the same "fuss", as if it is inside the machine. After a second or so, consumption goes up from 0.2 to 0.5A, while +5V input Voltage drops down, It stays thehre, then it does its usual "reset".

There is a switch which allows switching between FireWire and USB, but he works, his Signal goes into the Main ASIC.

Sorry for some Pictures being not rotated, but locally rotate before uploading them doesn´t help.
 

Attachments

  • expl3.jpg
    expl3.jpg
    547.3 KB · Views: 144
  • expl5.jpg
    expl5.jpg
    465.8 KB · Views: 142
  • expl10.jpg
    expl10.jpg
    681.8 KB · Views: 161
  • expl1.jpg
    expl1.jpg
    350.4 KB · Views: 152
  • epl9.jpg
    epl9.jpg
    712.4 KB · Views: 152
  • expl2.jpg
    expl2.jpg
    434.8 KB · Views: 149
Last edited:
Had someone tried to replace the USB socket before you acquired the device? Just wondering if there is another cracked or dodgy connection around there, possibly only showing up when a plug is in the socket?
 
Uuuuh, soldered myself one cap in the wrong direction. One moment, please...

It doesn´t seem that the USB connector itself was removed and reinstalled before i got it. No signs of resoldering. But i will check continuity between cable and Pins.
 
Good idea - but no, it has continuity.

That issue seems to be overall far more deep down. Maybe its USB hat been going Nuts (for whatever reason). I have to check what under FireWire-Connection would happen. But i currently don´t have that connectivity.

Last chance is to ask Phonic or any other Manufacturer using this particular ASIC for help and/or Schematics. The serial Output of the Debug port doesn´t make sense at all - at any usual Baud rate/RX inverting/switching MSB-LSB order, other protocols like ModBus, 1-Wire etc. As i read in another Forum, it should output normal readable, serial log data.

This ASIC was also used in various A/V-devices, since it is multi purpose and not limited to this particular job.
 
Not going into the Logic Analyzer, but straight into a MAX232, looks a lot better. For future needs: Pin 1 of the Debug Port, Baudrate 115200

"
FLB running @ 24000000Hz; Flash Drivers: MX29LV320xB detected.

------------------------------------------------------------
Product Version: 5-1-32
LibraryVersion: BeBoB Package (Release)
LibraryBuildVersion: 7428 (2008-05-14 07:11:15)
LibraryTag: UNKNOWN-TAG
------------------------------------------------------------


Starting Bootloader Level 1
- Verifying application image: OK

Starting Image


ÿ

Copyright 2000-2010 by Archwave AG, Duebendorf, Switzerland

Type Start End Size
Heap cached 0x6017c770 0x60600000 0x00483890/4733072
Heap non-cached 0x70600000 0x70800000 0x00200000/2097152
AHB0 cached 0x004031ec 0x00410000 0x0000ce14/52756
AHB0 non-cached 0x00500000 0x00510000 0x00010000/65536
AHB1 cached 0x00413f10 0x00418000 0x000040f0/16624
AHB1 non-cached 0x00510000 0x00518000 0x00008000/32768
TCMD 0x0054142c 0x00542000 0x00000bd4/3028
TCMI 0x00583f80 0x00584000 0x00000080/128
Text 0x400c2df0 0x40400000 0x0033d210/3396112

Stacks Start End Size
timer 0x00540ca8 0x005410a8 0x400/1024
supervisor 0x00540728 0x00540b28 0x400/1024
user 0x00540b28 0x00540ca8 0x180/384
irq 0x005405c8 0x00540728 0x160/352
fiq 0x6017975c 0x6017977c 0x20/32
undef 0x601796dc 0x6017975c 0x80/128

module: gpioModule... [255C[10D[ [32mok[0m ]
module: SysDevUart0... [255C[10D[ [32mok[0m ]
module: SysDevUart1... [255C[10D[ [32mok[0m ]
module: SysDevSPI... [255C[10D[ [32mok[0m ]
module: FlashDrivers... MX29LV320xB detected.[255C[10D[ [32mok[0m ]
module: cneModule... F CnE from Flashound a 64kbyte blocked flash
Persistent Parameter at 0x10000, size: 0x10000
[255C[10D[ [32mok[0m ]
module: persistentCnEParameter... [255C[10D[ [32mok[0m ]
module: systemDataService... [255C[10D[ [32mok[0m ]
module: cneSystemDataMgr... [255C[10D[ [32mok[0m ]
module: AudioHWService... [255C[10D[ [32mok[0m ]
module: UIServices... [255C[10D[ [32mok[0m ]
module: HALCompatibilityService... [255C[10D[ [32mok[0m ]
module: chekovModule... [255C[10D[ [32mok[0m ]
module: FireFly_808U_HAL... Instantiating FF808U hal
[255C[10D[ [32mok[0m ]
module: StreamDeviceManager... [255C[10D[ [32mok[0m ]
module: StreamDeviceObserver... [255C[10D[ [32mok[0m ]
module: IsoStreaming... [255C[10D[ [32mok[0m ]
module: stack1394NoBusReset... [255C[10D[ [32mok[0m ]
module: modCMP... [255C[10D[ [32mok[0m ]
module: bldCommandProcessor... [255C[10D[ [32mok[0m ]
module: StreamDeviceAv... [255C[10D[ [32mok[0m ]
module: StreamDeviceArm... [255C[10D[ [32mok[0m ]
module: StreamDeviceUSB... [255C[10D[ [32mok[0m ]
module: StreamDeviceUSBAsync... [255C[10D[ [32mok[0m ]
module: StreamDevice1394... [255C[10D[ [32mok[0m ]
module: StreamDeviceFramer... [255C[10D[ [32mok[0m ]
module: StreamDeviceDeframer... [255C[10D[ [32mok[0m ]
module: Services1394... [255C[10D[ [32mok[0m ]
module: AVCStack... [255C[10D[ [32mok[0m ]
module: AVCConnectionMgnt... [255C[10D[ [32mok[0m ]
module: HighSpeedCtrlService... [255C[10D[ [32mok[0m ]
module: StreamMonitor... [255C[10D[ [32mok[0m ]
module: ChekovUSBBusDriver... [255C[10D[ [32mok[0m ]
module: USBStack... [255C[10D[ [32mok[0m ]
module: USBHighSpeedCtrlService... [255C[10D[ [32mok[0m ]
module: USBDeviceHandler... [255C[10D[ [32mok[0m ]
module: StreamingFrmWrk... [255C[10D[ [32mok[0m ]
module: DataStreamManagement... [255C[10D[ [32mok[0m ]
module: sdsShellModule... [255C[10D[ [32mok[0m ]
module: flashBurn... [255C[10D[ [32mok[0m ]
module: Application...
------------------------------------------------------------
LibraryVersion: BeBoB FF808U App (Release)
LibraryBuildVersion: 8058 (2011-02-28 16:06:29)
LibraryCVSTag: Phonic_FireFly_808U-5_1_32-8058_RC
------------------------------------------------------------

Execute batch from
No leaf name "" found
sdsShell ready for commands. Try "help" for help.
sds://>
Bus-select switch set to USB

*** Running USB ***


~~~~~~~~~~~~~~~
Standard mode
~~~~~~~~~~~~~~~

Config: Recorder, standalone USB: 7 PacketsInMonitorOutputQueue, 10 MonitorChannels to Playback
Config: Playback, standalone USB: 7 PacketsInMonitorInputQueue, 10 MonitorChannels from Recorder
[255C[10D[ [32mok[0m ]
System initialisation done.
Playback: InStream Off, Standalone
Std: 12 x 12 channel + 1 MIDI playback running
Recorder: OutStream Off, Standalone
Std: 12 x 12 channel + 1 MIDI recorder running"
 
Currently it doesn´t respond to RX (@3.3V Logic level). Maybe they disabled RX on hardware level - or the ASIC needs to be in a special mode.

BTW: I got debug output by powering the CPU Board externally. If it is reinstalled into the System, it resets at "verifying..." as it has done before repeadetly. So the Voltage drop/reset is, as it seems, a PSU issue.
 
Well, USB issue seems do be "very deep". Specs say that USB needs +3.3V on D+ or D- in order to recognize any connected device. Since it doesn´t reach that voltage (approx half of it, depending on D+ or D-). it looks like that the internal Port of the ASIC, at least of the USB Port, is "dead". Adding an external pullup won´t work, because the USB System, which could eventually respond to the Host request, gets initalized way after boot up.

My only hope at the moment is, that the FW Port isn´t affected too.

Well, that "loose D+ wire" must have had a reason too. I guess something was overvolting (perhaps not only from the PC), so it banged straight into the USB Port and eventually into the ASIC.

Too bad.
 
Last edited:
Uh, the KORG Zero4 Service Manual contains an DM1500 ASIC. One of the -very few- ones, if not the only one. Because all other Audio Interface Manufacturers using this ASIC didn´t release any Service Manual.
 
Last edited:
Yes, the ASIC has separate VDD/VSS-Inputs for driving the internal USB Port, so i was hoping that VDD/VSS was not given, but no, its there. So that Port is definitely dead.

I hope that this doesn´t apply to the Firewire-Port too, because apart from 3.3 Volts on the Power Pins, i cannot measure there any voltage either. But it might be that FW works quite different in terms of "who delivers signal power" or, due to the fact of external powering the PCB, that an external high voltage for driving the FW Port is currently missing. I have to sort out that PSU issue first.
 
I assume you are absulutely right. I´m not aware of the functionality of a FireWire-Interface; never had any contact with it before because even my Computers were not equipped with it.

In case of my faulty board, FireWire is handled/driven by a "normal" IC, separated from but controlled by the ASIC and also gets only +3.3V for operation. I was concerned about the fact that even its differential Data lines didn´t show any signs of voltage, but that seems to be normal, considering the fact that FireWire operates in the Amps range for driving the Data Lines - which could under no circumstances being provided by the faulty Board.
 
Yep, Connection through FireWire works at least under Ubuntu 22.10 and PulseAudio, also with JackD, there it pops up as "FireFly/Helixboard" and "Firefly_808U". Last thing to sort out is the PSU issue; i hope this will be a small thing to solve and not being related to a faulty IC on the Amp side.
 

Latest threads

Back
Top