Continue to Site

Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Ultrasonic Reverse Parking Sensor not working

skmdmasud

Member
Hi..
my car has ultrasonic reverse parking sensor
sensor: https://boodmo.com/catalog/part-reverse_park_assistance_sensor-39703254/
controller: https://boodmo.com/catalog/part-contro_ller_assy_park_snsr-6774033/

When putting the gear in reverse it make the 1st initialization long beep, after that it is silent. Rarely randomly it starts to work for few seconds then stops. We swapped the sensor and controller from another brand-new car but same result.

Wire continuity from sensor to controller is ok, for other wire need to know the inputs/outputs or pinouts so that we can diagnose the wires.

Any help will be apricated.

Regards.
 

skmdmasud

Member
Did you check the grounds. Unscrew and remove a bit of paint under them. The controller or sensor may ground through mounting screws.
Poor grounding is a common cause of automotive intermittent failures.
I am also suspecting grounding issue. I have noticed that when the car interior is hot like parking in the sun the sensor started to works. Now in summer it works more frequently.
Does resistance between connection decreased as is gets warm?
 

Latest threads

New Articles From Microcontroller Tips

Top