• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Solid State Tesla Coil Burning IGBTs

Status
Not open for further replies.

Jesus Rodriguez

New Member
Hi, I replicated the one tesla circuit for a dual resonant tesla coil, followed all the instructions of how to assemble the circuit and how to wind the coils, when I decided to test it first i connected the input to a 48v 5A transformers to be sure all the connections were right and it turned on, the arc was pretty small about 2cm so i decided to make a full power test, the coil is supposed to be designed to be conected to mains voltage,(120 vac) so thats what did, but when I turned the interrupter on, one of the traces blew and the IGBTs died, so i replaced the IGBTs and did the 48v test, again it performed with no problem, this time I decided to increase the power slowly, adding another 48v 5A transformer in series also I double checked my conections and the cap and the inductance calculations with java TC, but again when I turned the interrupter on, a pop sound was heard and the IGBTs died again.

Any ideas? Also here is the circuit that you can find on one tesla. http://onetesla.com//media/wysiwyg/downloads/tsschem.png
 

Attachments

tcmtech

Banned
Most Helpful Member
You likely need a pair of diodes in parallel with the two 1000 uF capacitors that make up the other half of the H-Bridge.

Odds are you are getting big inductive voltage spikes that are overpowering the IGBT's, because the back end of the inductive spike has no path to freely flow through, and is what is blowing them out since there is a limit to what the capacitors can cope with due to either higher than ideal ESR values or some other normally secondary effect associated with them in this type of application.

Just a guess but I have worked with multi to tens of KW SMPS units that used similar H-bridge primary circuits and typically they used high speed diodes in parallel with the capacitors to correct inductive overvoltage overshoot issues that would otherwise possibly damage the primary switching devices that made up the other half of the H-bridge circuit.
 

Jesus Rodriguez

New Member
So.. i guess the 1.5ke510ca diodes right next to the IGBTs are not enough?
by the way the primary coil is connected in series next to cpri marked on the diagram
Also, wouldn't this diodes lower the output? since they will cut the high voltage spike that is needed for the coil to work and resonate.
If so, which diodes can you recomend me?

thank you very much I've been looking for some help for a long time
 

tcmtech

Banned
Most Helpful Member
The spikes need to have a complete path to follow from the postive railot negative in both directions of current flow otherwise they will simply blow through the point of least resistance which is the IGBT dies peak voltage limit or the capacitors guts. There's not really any way around it.

As for diode specs look for something that has a similar or better rating than the limits of the IGBT's in both speed and current. At worst you may want to add some low ESR bypass capacitors in parallel with your bigger ones in order to give the high frequency inductive noise an extra path to follow. It can't really hurt a circuit like this given your 1000 uF units are more than likely power electrolytics which by design tend to have rather poor high frequency characteristic to begin with.
 

dr pepper

Well-Known Member
Most Helpful Member
I'm not familiar with tesla coils, but I have some smps experience.
I'd agree with Tcm, tesla primaries no doubt have loads of leakage inductance as the primary is well clear of the secondary, this being the case there will ne large spikes in the primary, looks like the designer has thought of this adding the transorbs, did you put them close to the fets?, and have you checked them after the little incident?
Also your wiring around the power section needs to be fairly hefty and as short as possible.
Is that a Led/photo cell bottom left for an audio in?, photo cells are not particularly great at audio freq's.
 

Jesus Rodriguez

New Member
I'm not familiar with tesla coils, but I have some smps experience.
I'd agree with Tcm, tesla primaries no doubt have loads of leakage inductance as the primary is well clear of the secondary, this being the case there will ne large spikes in the primary, looks like the designer has thought of this adding the transorbs, did you put them close to the fets?, and have you checked them after the little incident?
Also your wiring around the power section needs to be fairly hefty and as short as possible.
Is that a Led/photo cell bottom left for an audio in?, photo cells are not particularly great at audio freq's.
Thank you very much, my IGBTs are the FGH60n60, yes i checked the transorbs and all appears to be ok, also they are right next to the IGBTs but i will put another diodes next to the 1000uf caps i choosed this ones 1.5KE510ACT-ND are they ok? or should i choose a lower voltage rating so it triggers before they are unidirectional while the transorbs next to the IGBTs are bidirectional, hope this works
Also at the bottom is a fiber optic reciever not a fotocell.
thanks.
 
Last edited:

dr pepper

Well-Known Member
Most Helpful Member
According to the number the igbt's will stand off 600v, and the transorbs start conducting at 510v so that seems to make sense.
If the igbt's are blowing through overvoltage then maybe the transorbs are not fast enough, or something else is happening.
I see the gate drivers are running off 15v, I thought at first that the igbt gates were being overdriven and blowing due to the gate drive transformer ringing, really there should be some gate overvoltage protection, and maybe a gate drive transformer secondary snubber, however if excess gate drive was your problem that would happen when you powered the thing from 48/96v.
Maybe Tcm is right, I'm not totally sure what he was thinking of there so I'd better let Tcm advise what diodes to use, I dont know if he meant 'standard' schottky diodes or transorbs.
Some smaller class x caps in parallel with the smoothing caps is a good idea as it would also keep spikes & noise away from the rectifier somewhat, which wont like it as they are most likely 'slow' diodes.
Like I said this isnt so much my field, maybe being air core the primary dv/dt is too high for the igbt's, a choke would tame that a little, however being dual resonant that might not be a good idea.
 
Last edited:

tcmtech

Banned
Most Helpful Member
As I stated before just find a diode that shares similar or better ratings to what the IGBT's have for voltage current and frequency and then install them to work in parallel with the two power capacitors just as the internal body didoes inside the IGBT's are connected.

By doing so you give the HF spikes a path to go that shunts them to the postive and negative rails of the power circuit so that they cannot grow any larger than the rail voltage is.

I would also add a few .01 - .1 uf Poly or other film type capacitors with as low as ESR values as you can find across the power rails and electrolytic capacitors so that those HV spikes have someplace to dump into that can absorb HF transients better than the electrolytics can.

Mostly what you are doing is giving as much of the HF noise a secondary circuit path to follow that will allow it to bypass the critical components and be absorbed harmlessly elsewhere. ;)
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top