1. Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.
    Dismiss Notice

Help regarding RFID Based Security Access System

Discussion in '8051/8951' started by KKS31, Feb 18, 2018.

  1. KKS31

    KKS31 New Member

    Joined:
    Feb 18, 2018
    Messages:
    3
    Likes:
    0
    I have been working on this project for a week, spending at least 2-3 hours daily on the computer trying to figure it out. I searched a lot of similar codes for this project and eventually, i successfully created a Hex file for the same. But the problem is that i am not able to run this on Proteus. The simulation starts successfully but nothing happens when i type, even the LCD doesn't display anything. It would be great if someone help me out because i am quite on the verge on loosing my mind here. I have absolutely no background on electronics and have to make this project because the subject requires it. I have included the Proteus file, C file and the HEX file. Please check it out and tell me what's wrong. Thanks!
     

    Attached Files:

  2. mik3ca

    mik3ca Member

    Joined:
    Jun 24, 2017
    Messages:
    436
    Likes:
    1
    A schematic of the actual hardware that you intend to plug your microcontroller into will help. If you don't have that, then you should tell us briefly how the LCD is connected to the micro (for example, what GPIO pin is connected to what pin of the LCD). Without this info, I don't think anyone can help
     
  3. KKS31

    KKS31 New Member

    Joined:
    Feb 18, 2018
    Messages:
    3
    Likes:
    0
    I have uploaded the pictures of the hardware. I successfully managed to run the program on proteus, but now on connecting the wires exactly as i did on Proteus, the Lcd isn't displaying any data. Plus when connecting the GND of the motor driver IC to the GND of the programing board, the programing board doesn't even start. I hope you can help mem
    Screenshot (11).png IMG_20180301_184955.jpg IMG_20180301_185131.jpg IMG_20180301_185058.jpg
     

    Attached Files:

  4. dave miyares

    Dave New Member

    Joined:
    Jan 12, 1997
    Messages:
    2
    Likes:
    -10


     
  5. mik3ca

    mik3ca Member

    Joined:
    Jun 24, 2017
    Messages:
    436
    Likes:
    1
    You might want to add longer delays for the LCD. Start with worst case. After changing the LCD enable line from 1 to 0 or from 0 to 1, have your program stall for at least 2ms.

    Also, consider adding at least a 10ms delay at the start of your program to allow everything to be fully initialized.
     
  6. KKS31

    KKS31 New Member

    Joined:
    Feb 18, 2018
    Messages:
    3
    Likes:
    0
    I did that, it works now. Thanks!
    I can't figure out the motor driver module connection. While giving Gnd connection, the main board doesn't work. iitriedito give Gnd to - ve on the board but that too didn't work.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice