• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Help regarding RFID Based Security Access System

Thread starter #1
I have been working on this project for a week, spending at least 2-3 hours daily on the computer trying to figure it out. I searched a lot of similar codes for this project and eventually, i successfully created a Hex file for the same. But the problem is that i am not able to run this on Proteus. The simulation starts successfully but nothing happens when i type, even the LCD doesn't display anything. It would be great if someone help me out because i am quite on the verge on loosing my mind here. I have absolutely no background on electronics and have to make this project because the subject requires it. I have included the Proteus file, C file and the HEX file. Please check it out and tell me what's wrong. Thanks!
 

Attachments

#2
A schematic of the actual hardware that you intend to plug your microcontroller into will help. If you don't have that, then you should tell us briefly how the LCD is connected to the micro (for example, what GPIO pin is connected to what pin of the LCD). Without this info, I don't think anyone can help
 

KKS31

New Member
Thread starter #3
A schematic of the actual hardware that you intend to plug your microcontroller into will help. If you don't have that, then you should tell us briefly how the LCD is connected to the micro (for example, what GPIO pin is connected to what pin of the LCD). Without this info, I don't think anyone can help
I have uploaded the pictures of the hardware. I successfully managed to run the program on proteus, but now on connecting the wires exactly as i did on Proteus, the Lcd isn't displaying any data. Plus when connecting the GND of the motor driver IC to the GND of the programing board, the programing board doesn't even start. I hope you can help mem
Screenshot (11).png IMG_20180301_184955.jpg IMG_20180301_185131.jpg IMG_20180301_185058.jpg
 

Attachments

#4
You might want to add longer delays for the LCD. Start with worst case. After changing the LCD enable line from 1 to 0 or from 0 to 1, have your program stall for at least 2ms.

Also, consider adding at least a 10ms delay at the start of your program to allow everything to be fully initialized.
 

KKS31

New Member
Thread starter #5
I did that, it works now. Thanks!
I can't figure out the motor driver module connection. While giving Gnd connection, the main board doesn't work. iitriedito give Gnd to - ve on the board but that too didn't work.
 

Latest threads

EE World Online Articles

Loading

 
Top