Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

tjerkotten

New Member
Hi, I am new on this forum, but I hope to learn more about this. I am working for the last 1,5 years with Motherboards of an old game console, the Dreamcast. Sometimes I have faulty motherboards. I replace the capacitors if needed and hope I can get it up and running again. I am currently working with a board that has a problem I can't seem to understand.

One of the capacitors seemed faulty. When I checked it with my multimeter, it had a continues beep, where it should be a short beep for good capacitors. I removed the 100uf 16V SMD capacitor and check it on it's own. It has the continues beep, so I replaced the capacitor with a new one, but still it would give me the continues beep when on the board.

I removed the capacitor again and check the pads itself on the board without the capacitor on. It also gives a continues beep, where it should be short. Is there something wrong with the circuit? Could someone give me some more information on this?

Thank you very much in advance. In this picture the pads aren't cleaned fully yet.
IMG_4370.jpg
 

Attachments

  • IMG_4371.jpg
    IMG_4371.jpg
    396.6 KB · Views: 25
  • IMG_4372.jpg
    IMG_4372.jpg
    704.1 KB · Views: 28
  • IMG_4369.jpg
    IMG_4369.jpg
    890.4 KB · Views: 28

Nigel Goodwin

Super Moderator
Most Helpful Member
Simple, there's a short somewhere else on the board - it's VERY common for there to be multiple decoupling capacitors on supply rails, and quite common for multiple ones to fail.

A good way to fault find these kinds of faults is to use a very low-ohm resistance meter as this will even measure the resistance of the tracks - so measuring across the one you've replaced might read something like 0.1 ohms, but measuring across the faulty on might only read 0.01 ohms, the extra resistance is that of the track.

Here's one a friend of mine built and uses.

 

Latest threads

New Articles From Microcontroller Tips

Top