Continue to Site

Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Connecting charger cable causes Sony WH-10000MX2 bluetooth headphones to stop working

Califauna

Member
Hi,

I have a pair of WH-10000MX2 bluetooth headphones with a strange problem. Connecting the charging cable causes the headphones to no longer turn on when pressing the power button.

I thought I had 'fixed' this when I took them apart and disconnected the battery for 15 minutes and found as soon as you disconnect the battery they can be powered on and off as normal using the power button. But then the moment you connect a charging or data cable to a charger or laptop USB port, the power button stops working and the can't be turned on again. No response.

The first time this happened the charging light would go out after a few seconds, which suggests it was a battery problem according to the user manual, but now it stays lit and it turns out the battery fully recharges. It just doesn't want to turn on again afterwards.

Any ideas? I thought I'd ask here before buying a battery in case there was something I could try.
 

Attachments

  • WhatsApp Image 2024-02-28 at 13.13.51.jpg
    WhatsApp Image 2024-02-28 at 13.13.51.jpg
    112.8 KB · Views: 43
I suspect when charging, all electronics are focused on charging the battery and not allowing the device to turn on. That is, the power on button is only enabled when there is no charging. It may be designed this way. Did it ever work while charging? What does the manual say about charging vs turning it on.
If it worked before while charging, then it may indeed be the battery A weak battery will draw the charging voltage lower than normal. However if it still turns on while not charging and runs on battery for a while, then it is not the battery itself.
 
I suspect when charging, all electronics are focused on charging the battery and not allowing the device to turn on. That is, the power on button is only enabled when there is no charging.

It's not only that it is not working when the cable is attached. Once the cable has been connected the device no longer turns on, even after the cable is removed. It will then only turn on again correctly once the battery has been disconnected then reconnected.

Every time you connect it to charge, it stops working completely (until the battery is disconnected momentarily).
 

Latest threads

New Articles From Microcontroller Tips

Back
Top