• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Archer intercom

Thread starter #1
Does anyone happen to know how the old archer wired intercoms transmitted?
I don't see any kind of mic on the board.
I just replaced all the caps and have it working on the receive side of the master control, I can page with the buzzer but don't have voice transmit to the satellite units.

Archer intercom.JPG
 

gophert

Active Member
#3
Does anyone happen to know how the old archer wired intercoms transmitted?
I don't see any kind of mic on the board.
I just replaced all the caps and have it working on the receive side of the master control, I can page with the buzzer but don't have voice transmit to the satellite units.

View attachment 115548
Yup, the speaker was also the microphone.
 

dr pepper

Well-Known Member
Most Helpful Member
#6
If your not transmitting voice audio but receiving it try cleaning the contacts in the talk/transmit switch.
 

gophert

Active Member
#7
If your not transmitting voice audio but receiving it try cleaning the contacts in the talk/transmit switch.
The speaker needs to be fairly stiff to work well. The fiberboard May have become quite "soggy" over the years which means they move a bit but the audio power of your voice may not be transmitting to the voice-coil of the "microphone" to generate a signal. A thin layer of varnish can crisp them up.

Alternatively, potentiometers fail as well so check if the pot has a dead spot. Replace or try spraying with "de-ox it."
 
Thread starter #8
Thanks for the input, it was the capacitor in the upstairs unit.
Two problems, one in each unit.
All there is in the satellite unit is a switch, speaker and capacitor.
When I tested the cap it had a 10% failure.
I was running out of things to test on the main unit so I took the basement unit and wired it to the main unit at the bench, it worked which pointed me in the direction of the upstairs unit.
Everything is back up and working.
 

Latest threads

EE World Online Articles

Loading

 
Top