• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

SIM800 APN erases

Status
Not open for further replies.

arhmrq

New Member
Good afternoon, I have a problem when connecting to the GPRS network with a cheap SIM800 L I bought on ebay.

After configuring it with the APN of my network provider (do not require a password):

AT+SAPBR=3,1,"Contype","GPRS"
AT+SAPBR=3,1,"APN","internet.nuevatel.com"
AT+SAPBR=3,1,"USER","VIVAINTERNET"
AT+SAPBR=1,1
AT+SAPBR=2,1

and establishing a network connection:

AT+HTTPINIT
: OK
AT+HTTPPARA="URL","http://miDominio.sth"
: OK
AT+HTTPACTION=0
: OK
: +HTTPACTION: 0,200,126
AT+HTTPREAD
: +HTTPREAD: 126
: {"valorAnalogo":"220","valorDigital":"1","createdAt":{"date":"2016-08-29 16:01:16.000000","timezone_type":3,"timezone":"UTC"}}
: OK
AT+HTTPTERM
: OK

I get sometimes a Good response, (like the one I got above) and sometimes I get no answer or ERROR,

After struggling a little bit I found that the APN gets erased sometimes (leading to this ERROR) and sometimes just remains, giving me a good answer, I check this with the Command:

AT+SAPBR=4,1
: +SAPBR:
: CONTYPE: GPRS
: APN: internet.nuevatel.com // This gets erased sometimes leading to error
: PHONENUM:
: USER:
: PWD:
: RATE: 2

I thought of the source but currently I am using a 5V 2Amp source and the ERROR remains, (less often I have to admit)

Is there anything I should know that Erases the APN and leads me to this problem??

I look forward to any Answer, thank you in advance.
 

fezder

Well-Known Member
You feed 5v directly to SIM800? IIRC, 5v is too much and causes SIM800 to reset due over-voltage.
I can't now test that with mine SIM, but I've played bit with it. Do you have external antennae connected?
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top