• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

MPlab8.92 stopped compiling - errors

augustinetez

Active Member
Has anybody else suddenly found MPlab 8.92 (or any MPlab8.xx version) suddenly not compiling asm files?

It is now giving me (partial list)these errors:

Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 33 : Illegal label (ORG 0x0000)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 34 : Illegal label (goto start)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 39 : Illegal label (clrf GPIO)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 40 : Illegal label (clrf sGPIO)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 41 : Illegal label (movlw 0x07)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 42 : Illegal label (movwf CMCON)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 43 : Illegal label (BANKSEL OSCCAL)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 44 : Illegal label (call 0x3FF)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 45 : Illegal label (movwf OSCCAL)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 46 : Illegal label (movlw b'10000000')
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 47 : Illegal label (movwf OPTION_REG)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 48 : Illegal label (movlw b'111101')
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 49 : Illegal label (movwf TRISIO)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 50 : Illegal label (BANKSEL GPIO)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 54 : Illegal label (btfsc GPIO)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 54 : Illegal label (3)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 55 : Illegal label (goto main)
Error[121] D:\PIC PROGRAMMING BACKUP\WENDY\TOGGLE 1.ASM 56 : Illegal label (call wait_10mS)

The icon against all my asm files is now what appears to be for C files and I can't find any way to switch the IDE to MPASMWIN.

Spent the last 4 hours deleting anything vaguely related to Microchip including any registry entries to no avail.

Edit: running Win 10 190something or other
 

atferrari

Well-Known Member
Have you tried to use a wrong .INC file?

INC files from 8.92 are not to be used with pic-as 2.32 or vice versa. Or should I say XC8?
 

augustinetez

Active Member
I've removed MPlabX - trying to do some maintenance updates on on old project files using MPlab 8.92 - it was all working a couple of days ago and I haven't changed anything.

Update on the icon against all asm files - it shows them as being associated with Visual Studio and switching the association to MPASMWIN has no effect.
 

atferrari

Well-Known Member
"Illegal label" seems to suggest that something is in the wrong column, maybe. Just guessing.
 

augustinetez

Active Member
Sorted - I must have used Switcher when I was using MPlabX to set something and it messed up - I know that is only supposed to be to do with driver files, but switching everything back to MPlab 8 seems to have fixed it.
 

Latest threads

EE World Online Articles

Loading
Top