• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

MPLAB ICD2 issue***!!!

Status
Not open for further replies.

Angy

New Member
I get this error below when I try to connect my icd2.

ICD0192: Failed to clear COM error. (RetVal = 0xFFFFFFF0, ErrRet = 0x0)
ICD0286: Unable to communicate with ICd

I tried using device manager to disable/enable it, it did not work.
Powered it on /ff, reboot the comp it still did not work. I can't seem to clear this error off.Does someone have any idea?
 

blueroomelectronics

Well-Known Member
If you have a com port try it. It will bypass the USB IC (usually a 18F4550) it may have corrupt firmware. Is it a genuine ICD2 or a clone like my Inchworm?
 

blueroomelectronics

Well-Known Member
Then try it with a serial port. The 18F4550 firmware on the ICD2 can get scrambled. It's rare but it has happend. Make sure you shut off the fifo buffers if you do.
 

Angy

New Member
DISABLE fifo buffer on Windows XP
1. On your PC, select Start>Settings>Control Panel.
2. In the Control Panel, double click the System Icon.
3. In the Systems Properties dialog, click the Hardware tab and click the Device Manager button.
4. Double click "Ports (COM & LPT)" to expand the Ports selection.
5. Double click the I/O port to which the MPLAB ICD 2 is connected.
6. Select the Port Settings tab.
7. In the Flow Control field, select Hardware.
8. Click the Advanced button, deselect the "Use FIFO" box, and click OK.
9. Reboot the PC to implement the change.
 
Last edited:
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top