• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

IC damaged?

Status
Not open for further replies.

Wond3rboy

Member
Hi when i try to program my 18f1320 it does the programming part then says verification failed at address 0x0000. Also all bits are set to 00 when ii read the IC.Is the IC permanently damaged?
 

blueroomelectronics

Well-Known Member
Did that work? Else you may have MCLR=ON and Internal OSC On, you'll need to connect it to the ICD connector which supports VPP before VDD.
 

be80be

Well-Known Member
Hi when i try to program my 18f1320 it does the programming part then says verification failed at address 0x0000. Also all bits are set to 00 when ii read the IC.Is the IC permanently damaged?
I've had that happen to on 18f1320 and 16f88 just force erase and she was good as new. The 16f88 has hung more. What's funny is it's only been when I use C18 on the 18f1320 and microC on the 16f88 the configure some how didn't set right. Like it didn't load it all when I programmed
 

Wond3rboy

Member
Did that work? Else you may have MCLR=ON and Internal OSC On, you'll need to connect it to the ICD connector which supports VPP before VDD.
It worked nicely.But what i found wierd is that why nothing happened when i tried normal erase before you advised the manual select technique.

I've had that happen to on 18f1320 and 16f88 just force erase and she was good as new. The 16f88 has hung more. What's funny is it's only been when I use C18 on the 18f1320 and microC on the 16f88 the configure some how didn't set right. Like it didn't load it all when I programmed
I will be moving to C in a couple of days, thanks for making me vary about the problem.

But i still think there is something wrong with the Ic cause i was forced to do it again.Will continue to do it though. These IC's are not available here.Had to import them.

The programs are correct since i test all my programs in Proteus to minimize debug problems.
Thanks for your replies.

Successfully used the UARt tool(tX ONLY).:)

But do i need to give the external supply a indicated in the PICKIT2 user's guide? Cause doing both Rx and Tx is causing porblems. Garbage data being transmitted and none recieved by the uc?
 
Last edited:
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top