• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Configuring XC8 with MPLab 8

Status
Not open for further replies.

Wond3rboy

Member
Hi

I have just done a fresh install on my system and have decided to move to MPLab8 since my PICKIT2 is not supported in MPLab X. However, I can't seem to compile code with any chip. I tried to compile some simple code with the 12F1840 I get the following error. I got the same for other chips too.

Executing: "C:\Program Files (x86)\Microchip\xc8\v1.34\bin\mcc18.exe" -p=12F1840 "main_motor_delay_switch.c" -fo="main_motor_delay_switch.o" -D__DEBUG -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
(922) chip "12F1840" not present in chipinfo file "C:\Program Files (x86)\Microchip\xc8\v1.34\dat\picc-18.ini"
(908) exit status = 1

PS: The compiler shows up as C18 in the toolsuite selection window.

Any suggestions?
 

Ian Rogers

User Extraordinaire
Forum Supporter
Most Helpful Member
PS: The compiler shows up as C18 in the toolsuite selection window.
No! That is always there.... The pic12f1840 isn't supported by pickit2 atall...

The XC8 installation hasn't been seen by MPLAB IDE... There is a little gripe about one version of MPLAB where the XC8 installation isn't right.... Its in the XC8 documentation somewhere..

They say you have to install MPLAB first ( I didn't and it still worked for me )
 

Wond3rboy

Member
Oh! I didn't look for the micro in the IC support list of the PICKIT2. Good that I have a PICKIT3 too :)

I like to use my Junebug (PICKIT2) though and thats why I wanted to shift back to MPLab 8 from MPLab X.

I have installed XC8 after MPLab 8.92. I will try to see if I can do something with it and post back.
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top