• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

AVR Studio Entering Programming Mode.. Failed!

Status
Not open for further replies.

Marks256

New Member
I just went to burn more code to a atmega16 i've been working on all day, and all of a sudden i got the error

Code:
Entering programming mode.. Failed!
Leaving programming mode.. OK!
with a "quick tip" saying something about making sure the ISP frequency is less than the clock. So i tried every number in the list of ISP freqencies, all the way from 921.6kHz down to 603Hz, and still no go.


This is the STK500 clone i'm using
AVR AVRISP V2.0 STK500 USB ISP Programmer for ATMEL IC - eBay (item 290326008241 end time Jun-28-09 17:08:56 PDT)


:( i really have no clue what is going on. Then i thought it was a problem with the fuses, so i started messing with them, and now i don't remember what they were set at. :(
 

Marks256

New Member
well it really doesn't matter anymore. I just managed to erase the firmware on the STK500 programmer...

I am going to call it a night before i start to start wrecking more stuff...
 

Marks256

New Member
Salgat said:
I hope I don't come off as rude, but why did you buy a clone when you could have bought the real deal for $3 more? :p
Not rude at all. I didn't know I could get the "real thing" still. Plus i was looking on ebay, and they don't seem to have very many real STK500's on there.

I bought a new STK500 clone yesterday, it should be here soon. Perhaps i'll be able to resurrect the broken ISP with the new one.
 

Marks256

New Member
My new STK500 Clone came, and programming failed again with the "Entering Programming Mode.. Failed!" error. So i swapped the Atmega16 for a new chip, and low and behold it worked! I am assuming a fuse decided to turn which put the device in program once mode.


So, it works now... solution was a new chip.
 

hack1nblack

New Member
clone upgrade how-to

the chinese clone avrisp use a different interface IC,
which wont firmware-upgrade via avr studio
so....to acheive the firmware upgrade use a little trick posted on the
AVRfreaks forum;a seriously cool resource for AVRmicro's!:)

edited version:-

If you upgrade the software while it is plugged into the target system, it corrupts the programmer.
You can force the programmer into boot mode by disconnecting it from the target system, and shorting TDI to TDO. If you have the 6-way connector (AVR ISP mkII) then you need to crack open the case and short pins 1,3 of the un-stuffed 10-way header (beside the USB connector)

it will then upgrade from AVR studio

solder in a 5x2 header and use a 0.1" jumper, so next time its easier
 
Last edited:
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top