• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Atmega328P failure no Signature with a solution

Not open for further replies.


I have a cheap atmega168 development board which I use for atmega328P. Programmer Usbasp, I have two, but that's of no consequence.
I've had about 3 non recoverable failures over several months. All tha same can't communicate, wrong/no signature.
All failures happened when I was developing a program, one minute everything was OK next minute dead!
Yesterday it happened again, but this time none of my remaining 3x atmega328p would work, all had the same problem.
An Atmega48 would work sometimes.
All this says to me something's wrong with the development board (I'd tried the other programmer).
The only thing I've done to the board is remove the 8Mhz Xtal and fit a socket, so I can use different Xtals.
One of my pet hates with comercial pcbs is that they only seem to handle one or two component removals/replacements before the pad/track disappears.
I removed the socket with afore mentioned damage to the track/pad, then fitted a 16Mhz Xtal (value is not important). I bent the Xtal pins so they reached the appropriate 22pF capacitor and soldered.
The remaining 3 mega328p now work! So it would seem that during programming loss or variation of Xtal signal can completely destroy the chip.
Breadboards are not the best for stable connections.

I don't know if a parallel programmer could fix the dead chip, but chip recovery pcbs cost about £12-15 and 5 x m328p costs about £6 from China.
So I'm not sure on the economics. Hopefully now I've discovered the Xtal fix I won't get any more lost Signatures.


Active Member
It seems to be a problem with the clock source.
To use the SPI You must have a proper clock source and the fuses had to be set right.

A longer time ago i had the same problem with an USB brigde that was connected to the programming pins.
There where generated some glitches that disturb the programming of the Chip, especially the clock setting.
My solution was to hold the reset pin of the USB Bridge inactive while programming the controller.

One Possible solution:
To wake up a so wrong fused chip you should connect an external clock about 1MHz to the clock input of the Controller.
Then connect the Programmer and set the clock fuses to internal clock ( default settings ) and the controller should wake up again.


Thanks, 4Mhz is the lowest Xtal I have, I'll try and rig up a 1Mhz external clock.
Judging by the number of posts on the internet about "lost signature", it seems to be a common event.
Many ppl use breadboards, I only use them if I must, and only for small circuits.
I've had too many experiments that didn't work on a breadboard but worked fine when soldered on a pcb.


Active Member
I've figured out that one of the issues on breadboard's is to low capacitance between the Power pins.
Or the wire to the next capacitator ist to long e.g. an experimental Power supply with long wires to the breadboard.
When a cicuit doesn't work try to install a bigger electrolyt capacitator between + and - at the breadboard.
And one additional 100nf ceramic near every used chip.
That will solve some Problems wit breadboards.
Not open for further replies.

Latest threads

EE World Online Articles