• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Device Signature reading fails (XMEGA-A3BU XPLAINED)

Rotto

New Member
Hello,

after I haven't done anything with my above-mentioned device the last years, I wanted to start programming again.

Making things short, I can't read the device signature. I used JTAG with my AVR Dragon connected to the red square pins in the one picture (layout). Microchip Studio is measureing the right Voltage, as seen in the attached picture (MC Studio).

The XMEGA also is working. My last program is running, when I power it via USB. I haven't really used the board, so I guess, I am the error, but I am a noob and maybe you can help me here. I would really like start to dive in into µ-controller programming and don't want to buy a new device now, since the XMEGA is a pretty good beginners board, I guess.

I have also attached the error message shown in Microchip Studio and the PCB-Layout.

Thank you for any help in advance.
 

riccardo

Member
I can't see any attachments.

When i have had device signature reading faliures its has been one of the following...
Bad connection between programmer and chip
Faulty programmer, or it just glitched and needed unplugging/plugging in
Bad target chip

9/10 times it has been the connection so I would look intot that first of all and make sure all the contacts are clean.
 

Latest threads

EE World Online Articles

Loading
Top