• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Transistor SPICE model for Multisim

Status
Not open for further replies.

duffmere

New Member
Hi, I'm currently doing a project involving SPICE simulation and I have a couple of problems with it. I'm generating a SPICE circuit file(.cir) based on a configuration file with a program I created. I don't have any problems generating the SPICE circuit file it's when I try to simulate it that I run into problems. I'll show you an example of a circuit file :

MTran1 1 VDD VDD 0 CMOSP L=180N W=500N
MTran3 0 1 VDD 0 CMOSP L=180N W=500N
Vin VDD 0 DC 1.8

.MODEL CMOSP PMOS LEVEL=3 PHI=0.600000 TOX=2.1200E-08 XJ=0.200000U
+TPG=-1 VTO=-0.9056 DELTA=1.5200E+00 LD=2.2000E-08 KP=2.9352E-05
+UO=180.2 THETA=1.2480E-01 RSH=1.0470E+02 GAMMA=0.4863
+NSUB=1.8900E+16 NFS=3.46E+12 VMAX=3.7320E+05 ETA=1.6410E-01
+KAPPA=9.6940E+00 CGDO=5.3752E-11 CGSO=5.3752E-11
+CGBO=3.3650E-10 CJ=4.8447E-04 MJ=0.5027 CJSW=1.6457E-10
+MJSW=0.217168 PB=0.850000

The model is one I took on the Internet since I will have the real simulation model later on during the project.

When I run this file with Multisim, it generates a visual format of the circuit but they replace the transistor formats I've given by others in Multisim. Here's what it writes :

Importing SPICE netlist
File name: C:\Users\Personnel\Desktop\formatSPICE\formatSPICE\test.cir
- Component 'CMOSP' imported as 'MOS_4TEN_VIRTUAL' (RefDes MTran3)
- Component 'CMOSP' imported as 'MOS_4TEN_VIRTUAL' (RefDes MTran1)

I tried creating a new component using the component wizard and naming the component "CMOSP" but they keep changing the transistors I want to 'MOS_4TEN_VIRTUAL'. I don't know if this problem ever occured to anyone (hope I'm not the only one) but I'm kinda new with this stuff and I need to be able to generate the right kind of transistors if I want my simulation datas to be as accurate as possible. Thanks !
 

crutschow

Well-Known Member
Most Helpful Member
I tried running your circuit in a old copy of Electronics Workbench I have (which evolved into Multisim). I placed your circuit into a .cir text file and then imported it to Workbench. It seemed to work correctly, showing two transistors in the generated schematic with the label "CMOSP".

So it's not obvious to me why it's not working for you. You may have to try contacting the vendor to see if they can help.
 

duffmere

New Member
Well, it doesn't really answer my question but thank you, At least now I know the file I'm generating is correct. I'm gonna try to write an e-mail to Multisim Support team (if there is one)...if anyone knows why Multisim won't display the transistors with the characteristics in my circuit file you can always post the answer....it would be really appreciated.
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top