• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

The H Bridge can't simulation on Proteus

Status
Not open for further replies.

laoadam

New Member
I made a simple 4x IRF3205 H Bridge for testing some thing out, the breadboard works well, but can't simulate on Proteus.
The schematic and error message attached, please help.
H Bridge T1 post.JPG
 

audioguru

Well-Known Member
Most Helpful Member
The parts on your schematic are so far apart that the parts and text are too small to read.
 

ronsimpson

Well-Known Member
Most Helpful Member
Again, the text is too small to read.
This is not how to make a H bridge.
The bottom MOSFETs, (Q2, Q4) have a Gate to Source voltage of 0 or supply voltage. (can't read what the supply is) The MOSFETs have a G-S max voltage of 20V. In spice this is not a problem but in real life 24V will kill parts.
The top MOSFETs are driven wrong. They are not turned on well. If the Gate is pulled up to 24V then the source will only be at 19V.
We do not know what the two switches are doing. From what we know, of your circuit we can not tell if all the FETs are off or all are on or what.
"too much CPU load" probably is: spice can not get started. It does not know the starting condition.
 

ronsimpson

Well-Known Member
Most Helpful Member
What controls the switches?
Please try this. One switch open and the other closed. (no switches, just wires)
1550888418163.png
 

audioguru

Well-Known Member
Most Helpful Member
Please do not save and post your schematic as a fuzzy tiny JPG file type. Even when I enlarged it I cannot read the text. Make the schematic much larger and use PNG file type instead that is very clear.
How many volts does the motor need?
What is the voltage of the upper Mosfets drains?
What is the voltage of the Mosfets gates?
What is the voltage at the left motor wire?
What is the voltage at the right motor wire?
Do you know why the upper right Mosfet is barely turned on?
 

ChrisP58

Well-Known Member
Most Helpful Member
I see that there are junction spots where the four resistors connect to the gate wires. Also where the motor connects to the vertical wires running between the upper and lower mosfets. But I do not see junction spots were the gnd symbol connects to the wire connecting to the source pins of the lower mosfets, nor where the +12V connects to the drains o the upper mosfets.

So, I wonder if you have a power connection problem.
 

Ian Rogers

User Extraordinaire
Forum Supporter
Most Helpful Member
I see that there are junction spots where the four resistors connect to the gate wires. Also where the motor connects to the vertical wires running between the upper and lower mosfets. But I do not see junction spots were the gnd symbol connects to the wire connecting to the source pins of the lower mosfets, nor where the +12V connects to the drains o the upper mosfets.

So, I wonder if you have a power connection problem.
Well spotted... That certainly makes the schematic work... Once you place the 20v and 12v power you need to add the rails..

Select "Design" on the menu and sub menuitem "Configure power rails"... make "New" rails and add the missing power supplies to them..
 

audioguru

Well-Known Member
Most Helpful Member
on the tiny schematic I think the drains show a 12V power supply and the same 12V for the gates that will not work.
 

laoadam

New Member
Please do not save and post your schematic as a fuzzy tiny JPG file type. Even when I enlarged it I cannot read the text. Make the schematic much larger and use PNG file type instead that is very clear.
How many volts does the motor need?
What is the voltage of the upper Mosfets drains?
What is the voltage of the Mosfets gates?
What is the voltage at the left motor wire?
What is the voltage at the right motor wire?
Do you know why the upper right Mosfet is barely turned on?
Thank you. I'll improve the picture.
How many volts does the motor need?
24V
What is the voltage of the upper Mosfets drains?
??
What is the voltage of the Mosfets gates?
20V
What is the voltage at the left motor wire?
??
What is the voltage at the right motor wire?
??
The '??' need to get next time test.
 

laoadam

New Member
Well spotted... That certainly makes the schematic work... Once you place the 20v and 12v power you need to add the rails..

Select "Design" on the menu and sub menuitem "Configure power rails"... make "New" rails and add the missing power supplies to them..
Thank you.
That was done.
 

alec_t

Well-Known Member
Most Helpful Member

audioguru

Well-Known Member
Most Helpful Member
The lower Mosfets are now getting a Vgs of 20V to turn on which is their absolute maximum allowed voltage, you should divide down the Vgs to 10V.
 
Status
Not open for further replies.

EE World Online Articles

Loading
Top