• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Still no power to the display panel, Samsung 50" Plasma TV

Status
Not open for further replies.

stevefivey

New Member
Hi,
Ok, so I replaced the PSU, good as I now have power to the switch ( dead before ) the tv switches on ( I hear the usual click ) from there I got a flashing LED on the main logic board, I managed to pick one up on ebay from a good company, installed it, same thing :(
Ok, so I'm now thinking it might be the Y main board?? Would this be the cause of absolutely no power going to the screen? The screen is dead, doesnt prime, no colours, no menu or volume bar?? Is there a way of checking certain things on the Y main with a volt meter in circuit to confirm if it is the Y main? There is definitely power getting to the Y main which I have checked. Any help appreciated, before I start selling the bits on ebay ;)
 

unclejed613

Well-Known Member
Most Helpful Member
what's the LED blink code on the power LED?
is there a pattern to the LED blinking on the main board?
 
Last edited:

stevefivey

New Member
ok, on the logic board there are 3 LED's ( 2000,20012002 ), when I switch the TV on LED 2000 and LED 2001 come on, after about 2-3 secs LED 2000 stays on LED 2001 goes off and LED 2002 comes on and blinks repeatedly. hopw this helps, cheers
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top