• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Replacing a 4 pin leaded inductor with a 2 pin

Status
Not open for further replies.

gkmaia

Member
I am struggling to find a 4 pin replacement for my 560k H18 inductor.

I suspect any 2 leaded 58uH coil will do as the extra 2 pins are not doing much extra. But I could be badly wrong. Could anyone confirm before I do something bad?

What I got available here in Nz is a ELC09D560F - Panasonic 56 μH ±10% Ferrite Leaded Inductor, 1.1A Idc, 130mΩ Rdc ELC09D

I also have a complementary question. This inductor was making a very loud whine (pin points each component with a soundscope and it was screaming. What would usually make an inductor whine too loud? Inductor failure (how if it just a wire)? Surrounding components failing, capacitors, traces...? Power source issues?

Any help I appreciate.

IMG_2151.JPGIMG_9500.JPG
 
Last edited:

Nigel Goodwin

Super Moderator
Most Helpful Member
Usual failures are electrolytics, going high ESR - is the PSU still working OK, apart from the noise?.

The only 'fault' that could cause the inductor to whistle is loose windings, and that doesn't appear to have the windings fixed in any way - and it wouldn't affect operation.

I've repaired huge numbers of SMPSU's (thousands of them over a long period), and have never had such an inductor fail - there's not really anything to go wrong with them, and as it's a thick piece of wire it's unlikely to break.

As you can clearly see from the PCB picture, it's simply a two wire inductor, the extra pins are for mechanical stability.
 

schmitt trigger

Well-Known Member
Agree with Nigel.

Power inductors can sustain heavy overloads for significant amounts of time.
Eons actually, specially compared to semiconductors.
 

MikeMl

Well-Known Member
Most Helpful Member
Four-leaded inductors are usually deployed as a common-mode choke in a differential pair of wires, like the power cord on a power supply... Trace out the circuit to see if this is the case. If yes, then a two-leaded inductor will not do.

Inductors rarely go bad.
 

Nigel Goodwin

Super Moderator
Most Helpful Member
Four-leaded inductors are usually deployed as a common-mode choke in a differential pair of wires, like the power cord on a power supply... Trace out the circuit to see if this is the case. If yes, then a two-leaded inductor will not do.
Perhaps you should look at the excellent pictures he posted? :D
 

MikeMl

Well-Known Member
Most Helpful Member

gkmaia

Member
Will it do any harm if I try to turn the device on without this inductor? That would be a good test to determine if it was actually the source of the whining.
 

Nigel Goodwin

Super Moderator
Most Helpful Member
Will it do any harm if I try to turn the device on without this inductor? That would be a good test to determine if it was actually the source of the whining.
It could well be catastrophic - don't do it.

What's with the capacitor just to the left of the inductor on the board?, it appears to be partially removed.
 

MikeMl

Well-Known Member
Most Helpful Member

dr pepper

Well-Known Member
Most Helpful Member
I've had inductors fail on industrial equipment, but when they do they are nuked.
 

JimB

Super Moderator
Most Helpful Member
Perhaps you should look at the excellent pictures he posted? :D
What pictures?
In post #1, nice big pictures of the inductor, and of the PCB.
I see no pictures in post #1 of this thread????
I can’t either
And neither can I when I use Chrome as my browser.

However, If I revert back to good old MS Internet Explorer, I can see two little placeholder boxes for links that don't work.
Examining the properties of these boxes shows that they appear to be linking to something on AAC.

Why could the OP just not have posted the pictures here?

JimB
 

MikeMl

Well-Known Member
Most Helpful Member
I am using firefox...
 

Pommie

Well-Known Member
Most Helpful Member
For future reference, any pictures would be better posted to this site as many posters, including myself, can't see your pictures and therefore cannot help.

Mike.
 

gkmaia

Member
For future reference, any pictures would be better posted to this site as many posters, including myself, can't see your pictures and therefore cannot help.

Mike.
That is correct. My mistake.

I have made a similar post on all about circuits and has used that code to generate a similar post here.
The users who could see were the ones with a current open session on all about circuits at the time. You are probably not on that forum, so you could not see.

I will keep my eyes open so that wont happen.
 

gkmaia

Member
It could well be catastrophic - don't do it.

What's with the capacitor just to the left of the inductor on the board?, it appears to be partially removed.
The capacitor was raised so I could have access to the traces underneath it. The previous capacitor leaked and damaged the traces.
 

gkmaia

Member
As a feedback for the whine. I unwired the coil. Rewired it with a good coat of varnish and put it back. It is 90% quieter now.
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top