Continue to Site

Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

LG42PQ30R plasma Tv with no picture

Status
Not open for further replies.

brainbaby

New Member
Hi friends,
This is my first post in this forum and I hope I would fetch some of your valuable time

Let me brief, long story short..
I am working on an LG plasma TV model 42PQ30R.
The fault is no display.
The tv is turning on, the blue led is working, however there is no standby (red light), tv automatically going in run mode (i.e blue led)
Note: sometimes gets off automatically but it happened only once or twice.

I began my troubleshooting with the power supply, all fuse ok.
power supply ok, getting the required panel voltages (Vs and Va) at power supply outputs.

My next step was to check the Ysus board.
Ysus P201 to SMPS P812 connector is OK.
Ysus P209 to left X drive --ok
checked the MOSFETs, IGBTs, all ok except a few, IRGP 4086, IRFP 4332, K3667 (2), but cannot confirm as they were tested onboard, not standalone.
Ysus P206 to Z sus ---doubtful, reason -fluctuating voltage received at Er com and VS pins which should be as per panel label i.e 94.9 and 193 V respectively.
Not checked the floating voltages at P207 (Ysus to Y drive), as I haven't ascertained pins where and how to measure floating voltages, I don't have any isolation transformer.

My question is what seems to be the fault , am I going in the right direction, what should be my next step?

additional info- the fault started with the TV displaying coloured snow in picture and then by the time it went pitch black .
I am taking help from the LG training manual.

Regards!!
 
Last edited:

simpleGuy

New Member
Did you check the flex cables of the display itself?
they look like this:
maxresdefault.jpg
 
Status
Not open for further replies.

Latest threads

New Articles From Microcontroller Tips

Top