Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

EMI problems in PIC16F877a based Taxi meter

Status
Not open for further replies.

sdewinda

New Member
Hi all,
I am designing a Taxi meter for an Indian made three wheeler. That is 2 stroke 150cc Gasoline engine powered one.

Taxi meter worked fine when I test it form bench power supply. But in early testing time it’s going mad when the engine starts.

For minimizing EMI effects I did following modifications and preventive measures.

Decoupling caps to power line of PIC .1uF

Shielding the circuit using aluminum casing

Using toroid filter to power and metering pulse lines

Using shielded cable to metering pulse line

Used copper pour in PCB

Problem solved to sertent extent .But still occasionally its resetting.
I checked other possibilities of resting like power or errors in code. But still I suspect due to EMI interference it happens

Are there any more things to minimize EMI?
 

jimmythefool

New Member
1: Make sure you're copper pour is connected to ground plane. Don't leave any unconnected islands.
2: decouple ALL I/O leaving the PCB, near the connector.
3: Keep your reset pin away from any I/O leaving the board
4: Make no inputs are floating, use pullups, (Internal pullups may not be strong enough.) 4K7 is a good value.
5: Transzorb across the board supply.
6: 330R-1K series resistor on onput lines
7: Good board layout.

The list goes on..

Regards

Jim
 

mvs sarma

Well-Known Member
the sensor should be isolated if possible from the device
I feel , that the rotary item is still used which is correct for the distance measurement and billing thereby. this device acts like an antenna. so precautions need to be taken to avoid metalic contact with the meter at the near end.
the voltage derived from the generation is too spiky and the regulator should better have transzorbs as already suggested by Jim.
 

sdewinda

New Member
Thanks guys
2: decouple ALL I/O leaving the PCB, near the connector.
I guss you mean to connct 0.1uF caps to the ground. correct me if I am wrong

3: Keep your reset pin away from any I/O leaving the board
reset pin in pulled up with 1k only . will it be better to decouple?

5: Transzorb across the board supply.
my power supply is about 2m away from PIC its connected via a screened cable. I have done filtering there. Is there any posibility to induse EMI through screend cable.

There are some IO pins left unused they are not connected to any path. are thay need to be decoupled or pulled up

there are PGC PGD and MCLR paths in board they left floting when programmng cable is removed . I feel they may also effected. any comment on this.
 

smanches

New Member
MCLR pin MUST be pulled up by a resistor. It's a reset pin, and left floating will cause random resets.
 

jimmythefool

New Member
Yes, 0.1uF is good, cut the legs on the caps as short as possible.

The power supply decoupling wants to be on the PCB, as close to the connector as possible. Is the screening grounded? The screening is useless if not properly terminated.

You say the reset is floating, and also say its pulled high by a 1K resistor :confused:

All unused pins should be set as Output Low

Hope this helps

Jim
 

Diver300

Well-Known Member
Most Helpful Member
Put a capacitor between the reset line and ground. That way spikes are less likely to reset the PIC.

If you can, fit a capacitor large enough to keep the PIC running for half a second or so. You could be getting a brown-out.

On a Transit Van, the supply to the hazard lights dips to 4 v each time the lights flash. I think that is a current limiter or self-resetting fuse cutting in. You might have worse dips on something with a 150 cc engine.
 

shimniok

Member
This is probably off the wall but... could you possibly use spark plug wires that feature RFI suppression? What kind of ignition system is used on this engine? Magneto? Breaker? Electronic?

Michael
 

sdewinda

New Member
You say the reset is floating, and also say its pulled high by a 1K resistor
reset is pulled up by 1k. But the PCB path is kept long way in PCB to programming connector. When programming connector is not connected it can act as antanna.

This is probably off the wall but... could you possibly use spark plug wires that feature RFI suppression? What kind of ignition system is used on this engine? Magneto? Breaker? Electronic?

its magento , there ae no any RFI supressions. I tested my taxi meter in a Suzuki van it worked fine. But for the three wheeler I have to build a most robust one . There is EMI to at its max and spicks in power line also.
 

jimmythefool

New Member
A tranzsorb/capacitor will help with clamping the voltage spikes. It may help to 'can' your pcb too.

You need to find out exactly why your pic is resetting. It may be due to supply fluctuations, rather than/as well as Emi susceptibility.

how far is the pullup from the Mclr pin? It needs to be near the IC, not the connector.
 

sdewinda

New Member
2: decouple ALL I/O leaving the PCB, near the connector.
I decoupled input pins , Is it nessary to decouple output pins.

I am redesigning my PCB. I going to implement many of your sugetions . I will let u know when it works

Thanks for all sugetioins and if u have any further EMI experiance and solutions please let me know. It would be great help
 

jimmythefool

New Member
any input or output needs decoupling if its connected to a cable (aerial ) that can pick up noise and transfer it to your board.

use at least a double layer board, use the underside as a groundplane, and try not to put any signal traces on it.

good luck

Jim
 

mvs sarma

Well-Known Member
There is no point in discussion in the air without a specific schematic. We end up nowhere. the O P may post the schematic for further discussion
 

sdewinda

New Member
any input or output needs decoupling if its connected to a cable (aerial ) that can pick up noise and transfer it to your board.

is there any posibility of indusing noice in to shielded cable if shield is connected to ground.

if a system is totally encloded by a conductive grounded case is and all inputs are idally decoupled, can the system be totally free of EMI efects ?
I mean Faraday cage effect.

forgive me guys if I am asking too basic things
 

mvs sarma

Well-Known Member
is there any posibility of indusing noice in to shielded cable if shield is connected to ground.

if a system is totally encloded by a conductive grounded case is and all inputs are idally decoupled, can the system be totally free of EMI efects ?
I mean Faraday cage effect.

forgive me guys if I am asking too basic things

Generally the shield should be connected to ground only at one place and not both sides. Otherwise the shielding effect is lost due to longitudinal currents.
 

npolynomial

New Member
I beleive the problem has something to do with the I/O pins, like the previous user said.

Use pull up resistors or unused input pins.

Make sure no special features are turned on like, analog to digital converters, EUARTs, voltage detectors, etc... and if they are and are not needed turn them off. If they are needed make sure all interrupts associated with them are working properly or turned off. Also, make sure there isn't any type of confuration settings enabled for brown out reset, low voltage reset, watch dog timer, there's quite a few things that can cause this.

One thing that stands out to me is you mentioning it worked fine on the bench. Try to isolate signal inputs with optocoupling. I doubt the engines electrical frequency is affecting the chip, but I suppose it is possible.

Sincerely,

Jesse Randall
Electronics Engineer
Complete Turn-key Digital Electronics Design Nova Conceptions - Home
 
Status
Not open for further replies.

EE World Online Articles

Loading
Top