• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Decoupling/Error in PIC18F452

Status
Not open for further replies.

Dreak

New Member
I guess my PIC is either busted or there is a need of Vdd to Vss decoupling. As my circuit suddenly drops to voltage levels of zero as soon as i place PIC. though programmer does not show that there is any error with PIC. Program burns correctly. Last Test program that I did, ran correctly. Though I think the main reason for these voltage drops is PIC. Any reason why this happens?:confused:
 

Dreak

New Member
my programmer is entirely different from circuit. i use it just to program the device. so i guess it works properly. error lies in the board that I'm using.
 

Dreak

New Member
No short between Power & ground. If controller is removed off the board; all the voltage levels work as expected.
 

JimB

Super Moderator
Most Helpful Member
We could do with more information about your circuit, but lets try a few things:

I guess my PIC is either busted or there is a need of Vdd to Vss decoupling.
Decoupling will not cure the situation where the PIC kills the supply.


As my circuit suddenly drops to voltage levels of zero as soon as i place PIC.
Where are you measuring the supply, at the PIC supply pins, or, at the supply input to the board?
If the supply is OK where it comes on to the board, look for bad joints on the board between the supply and the PIC.


though programmer does not show that there is any error with PIC. Program burns correctly. Last Test program that I did, ran correctly. Though I think the main reason for these voltage drops is PIC. Any reason why this happens?
Dreak; said:
No short between Power & ground. If controller is removed off the board; all the voltage levels work as expected.
Could it be that your program is driving outputs which are causing a power short?
For example, a pin is configured as an output and turned on, but the pin is connected to the 0v line.

JimB
 
Last edited:

Dreak

New Member
supply is a battery. it is pretty fine. gives 7.5 volts. but sooner i place the pic, all the levels that are fed with the output of regulator(which gives 4.88V), start to get to 0v. not only that all levels turn to zero but the regulator input i.e. power from battery also gets altered & starts showing value 4V. also terminals of battery that are connected to board also get to voltage level of 4V.
 

JimB

Super Moderator
Most Helpful Member
Have you tried measiring the current taken by the circuit?

A 7.5v battery?
Is it really a 7.5v battery or a 9v battery which should have been replaced long ago?

JimB
 

alec_t

Well-Known Member
Most Helpful Member
.... or PIC wrong way round in socket?
 

Dreak

New Member
Have you tried measiring the current taken by the circuit?

A 7.5v battery?
Is it really a 7.5v battery or a 9v battery which should have been replaced long ago?

JimB
Yes it was a 9V battery. though this circuit draws that much current that it got dropped down to 7.5 in total work of just half an hour. I'm sure there is a short. Cannot figure out where it is though.
 

alec_t

Well-Known Member
Most Helpful Member
Try with a fresh battery. Does the PIC get noticeably warm? If it does, that suggests either it's outputs are trying to draw too much current or it has an internal high-current fault path.
What loads is the PIC driving? Do you have current-limiting resistors for the loads?
 

Dreak

New Member
digital multiplexer & LCD are the loads that i'm driving. I thought of putting 10K in series with the port pins. But is such a pull-up necessary; as for digital circuits, I guess Controller can source current that is enough. I haven't added certain high-power loads like motore to circuit yet. PIC doesn't get warm.
 

alec_t

Well-Known Member
Most Helpful Member
I thought of putting 10K in series with the port pins
That will certainly limit current but, depending on the input requirements of the loads, may prevent correct load operation.
But is such a pull-up necessary;
If the resistor is in series with the load I wouldn't regard it as a pull-up.
I guess Controller can source current that is enough
:confused: I thought the power source was a 9V battery?
 

Dreak

New Member
works finally; that too w/o decoupling cap. i'd poured too much metal at a particular contact causing short. took long time to find that bug.
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top