Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Anyone using Vinculum USB chip in DATA MODE?

Status
Not open for further replies.

shingadaddy

New Member
My second post here so hello all. Hope you're all safe and warm. ICE storm here last night and today

Just started posting/monitoring the electronic boards again after a several year hiatus. Using a Vinculum device and trying to get it to go into data mode by asserting DATAREQ (pin 36) low. Using UART config for interface. I can talk to the Vinculum and I can read and write to flash drives so I know my comm is good. If I have Nothing plugged into the USB ports or if I have a flash drive plugged into the HOST USB port 2, I never get DATAACK (pin 35) to go low like MFG doc's says it should. ( Yes there is no need for DATA MODE with a flash disk but MFG says DATAACK should go low.) I *CAN* get it to go low if I plug in a USB BLUETOOTH adapter. Goes low just as expected but of course the Vinculum firmware reports "UNKNOWN DEVICE". I can however QP and QD it and I get the expected responses back from the bluetooth dongle. Like I said, anyone using this device in data mode? I have this setup on 2 completely identical circuit cards and both do the same thing.

Firmware I am running is VDAP 3.66 downloaded from FTDI's site

Connections and signals all confirmed with a scope. It's gotta be a connection its unhappy with or a firmware oddity.

Any comments suggestions appreciated.
Thanks in advance.
 
Last edited:

shingadaddy

New Member
Okay. Any one of the 32 viewers using a Vinculum? <PERIOD>. Come on. Don't be shy.:rolleyes:
 

Ubergeek63

Well-Known Member
it is a bit messy. While I do not remember the details, only that you can not rely on their firmware for anything functions that their modules do not use.

I did the hardware and another engineer did the software. They do not use the parrallel interface option that I was ordered to implement. Control lines were the wrong polarity, commands improperly documented, etc. They "fixed" a bug in the firmware for their crap and broke the parrallel interface completely. After a month with their tech support they finally tried it themselves and said we were right. the last I knew we were going to ship interim firmware that actually worked the parrellel interface.

I do not know if my software guy would know or not. We were using the thing to access thumb drives with a micro. We program the micro flashmagic and then a software mode starts a seriel passthrough to program the vinc (the raw chips do not come programmed).

Dan
 

shingadaddy

New Member
Thanks Ubergeek63. Yeah I can get it to do the thumb drives. And yes they come blank (no firmware installed) when you just get the chip but they are already programmed with some firmware selections if you get one of their pre-built up modules. I got their firmware (VDAP 3.66) and their programmer from their website and flashed the VDAP firmware into the Vinculum. DATA MODE is what I am trying to get working, with the UART interface selection. Thanks for the reply and if you happen to get more info, I would appreciate it. I'll post my continued findings here. As I stumble across them.:eek:
 

shingadaddy

New Member
Just tried one of my new VDIP1 modules to see if it operated differently than I am seeing with my custom PCB. The VDIP1 module has a Vinculum mounted to it and came pre-loaded with VDAP 2.08. (REALLY OLD VERSION). But I thought I'd give it a shot. In fact it acts EXACTLY the same as my pcb with a vinculum device on it with the exception of not even being able to detect when a generic bluetooth device is plugged into it.

So I thought I'd go ahead and update the firmware to the latest posted to the Vinculum web site which is 3.66. Grabbed the RE-FLASH file this time and put it on the root of my flash drive. Re-named it as directed and plugged er in and sure enough, the Vinculum saw it and upgraded it's own firmware! :D Cool!

Now it detects the USB Bluetooth device as it is plugged in but of course it says it is an UNKNOWN DEVICE. And DATAACK works as advertised. However, DATAACK still does NOT go low after asserting the DATAREQ line low as the manual states, with NOTHING or a FLASHDISK plugged in. Even on the VDIP1.
Just like *MY* pcb.:mad:

Still waiting on Ftdi Support responses.

Meh.
 

shingadaddy

New Member
Well data mode works if you have a device plugged into the Vinculum port 2 that the Vinculum does not recognize. I am using it now to communicate to an intelligent bluetooth dongle. It acts exactly like FTDI data says it should. But 2 of my designed circuit boards and 1 of the VDIP prototyping modules from FTDI all act the same if nothing is plugged in or if a flash drive is plugged in. Can't get the DATAACK to go low by taking DATAREQ low. And I a making sure the Vinculum buffer is empty by shooting it a <CR> on the UART port.
 

shingadaddy

New Member
Yes I believe this is still true but there is an application for copying from one flash drive to the other through the vinculum. As far as I know, the device still only supports host on port 2 and slave on port 1. But I have it working with a bluetooth dongle that is one of the intelligent ones.
 

deepakrathinam

New Member
hi,
i am using pic18f controller and interfaced VNC1L via uart. Through hyper terminal i am able to create folder and files in usb flash drive but when i try with my firmware its unable to create, i am very new and i have no idea to figure out the issue, can someone help me in providing the debugging steps and any configuration to be taken care.

if required i can post my code too.

Regards
 
Last edited:

ironhyde123

New Member
WE are using VDRIVE2 with Firmware Ver 03.66VDAPF.We are interfacing it with our USB device which is a fingerprint sensor Morphosmart MSO CBM.Details of the Slave Device (fingerprint sensor):
- Communication Class Device in accordance with USB Device Class Specifications version 2.0
- The Device use full speed transfer rate of 12Mbits/s
- Compatible with USB 1.1 and USB 2.0 hosts and hubs
WE tested our sensor with a GET DESCRIPTOR string using the command mode. We are getting desired response when we send the 'DRD' command. But, on our application we don't want the command interface. We want to send/receive data transparently (i.e. w/o using any commands).
The GET DESCRIPTOR string is a data that we send to the sensor , after which the sensor replies:
SYNCïÿìName: CBM
Mobi5 Serial Number: 0944

This is our GET DESCRIPTOR string (18 Bytes):
$53$59$4E$43$04$00$00$00$FB$FF$FF$FF$05$01$00$2F$45$4E
In the above string $53 is a hex value, so we are sending 18 bytes written above in HEX format. We send these values using a Windows XP PC serial PORT. On the PC we are using Terminal v1.9b software (Bray++) and we send hex data using the transmit macros field in Terminal software.
Now while testing, we used the device in command mode initially. Selected the device SC 1 and then pulled the DATAREQ line (pin 36 of VNC1L) low (0V), after that the DATAACK line also became low. So now vdrive2 is in DATA MODE. But, now if we send the GET DESCRIPTOR string then we DON'T get the desired response. Rather we don't get any response from the device. Thus, we fail to interface the sensor in data mode.

But the same can be done successfully using command mode only and the following is the device log:
Command mode successful trial log:
Commands:
ipa
qp2
qd 0
qd 1
sc 1
dsd 18
%%%%%%%% Comment: send the GET DESCRIPTOR string (18 Bytes) using the transmit macros field in Terminal software. %%%%%%%%%%%%
drd

Responses:
D:\>
$10 $00
D:\>
$01 $20 $81 $10 $00 $00 $00 $10 $01 $02 $00 $02 $02 $01 $9B $07 $47 $00 $00 $01 $01 $00 $00 $00 $00 $00 $00 $00 $00 $00 $00 $00
D:\>
$01 $20 $83 $40 $02 $40 $03 $00 $01 $02 $01 $0A $00 $00 $9B $07 $47 $00 $00 $01 $01 $00 $00 $00 $00 $00 $00 $00 $00 $00 $00 $00
D:\>
$40
SYNCïÿìName: CBM
Mobi5 Serial Number: 0944D:\>

Our objective is to interface without using any commands after we select the device (i.e. after sc 1). We want to send our data (for eg. the GET DESCRIPTOR string ) directly to the sensor and get the response from the sensor without using any commands. P.S.:We have also tried the VCDC firmware and failed in a similar manner i.e. we didn't get any reply from the sensor.
 
Status
Not open for further replies.

Latest threads

Top