Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Any body build it? (12v to +35-35)

Status
Not open for further replies.

Blueteeth

Well-Known Member
and assemble that with SG3524 . ( in the schematic is SG3525)

Thats also a problem right there. Look at the datasheets for the SG3524 and 3525. Although they are very similar in terms of supply voltage and operating frequency, the push-pull outputs aren't available in the 3524. This should be 'ok' if you constraucted the circuit using the totem pole transistors to drive the mosfets (which shouldn't be required if you use a SG3525). But if you're driving the MOSFET's direct from an SG3525, the MOSFET's aren't being driven correctly. Trying scoping their gates to see if they are reaching the power rails 0 - 12V.

I would suggest reading, and RE-reading the original page. **broken link removed**
This has basic details on debugging and circuit operation. Also note there are TWO versions of this circuit.

Apologies if I seem like I am being rude, or patronising, its a tough project (aren't all switched mode power supplies?) with a LOT of variables. It makes building it with anything other than the original parts very difficult. In my experience it can be a minefield, that requires careful checking of waveforms with an oscilloscope - its why I stick to digital mainly lol
 
Last edited:

arvinfx

Member
Thanks to your attentions and the time that you expense for my project ;) ( and also apologies for my bad english )

You say about difficult of SMPS designing and it`s exactly right!

In my project use the TC4420x2 for mostefs driving and IRFP250 x 2 but in first stage i connect the Drain and Source incorrect! and i thing my mosfets blow up or damage! and one of my TC4420 burned !, if you show me way to test my mosfet it is very useful , i read the original page more and more... and i thing better to change my SG3524 to 25

Arvin
 

arvinfx

Member
It`s Work Now.
My problem was
1- Wrong transformer wounded.
2- Bad dead time setting
3- The wire that supply my circuit have high resistor and in 5.5A have 700mv drop on it and input voltage down to 11V and ratio on primary and secondary can`t provide my target voltage.
 
Last edited:
Status
Not open for further replies.

New Articles From Microcontroller Tips

Top