• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

About proteus 8 professional

Status
Not open for further replies.

Rutvik Chauhan

New Member
I don't know whether this is the right place to ask questions about proteus. If anyone knows please answer.
I am new to proteus 8 professional and I started to make isimple led blinking project. I import arduino uno from arduino library. But when I start simulation, it says could not open .elf file. I also tried for .hex file. Both didn't work.
Thanks in advance.
 

dknguyen

Well-Known Member
Most Helpful Member
Apparently, the software you use to produce your machine code affects what type of file Proteus wants. So in this case, I guess the question would be how did you create the Arduino Uno file when you imported it.

(I have no experience with Proteus. I can only try and give you ideas about how to find the answer to your question if no one else is responding).
 

Ian Rogers

User Extraordinaire
Forum Supporter
Most Helpful Member
If Proteus is not being run as administrator unless the hex file is in your documents, it won't be able to open it. If you have downloaded the newest Arduino IDE it will be in program files(x86) and any sample will also be there. If you close Proteus and "Run as Administrator" it will be able to open the files..

If you have modified the schematic and you are running in free mode, it wont run it..
 

Rutvik Chauhan

New Member
If Proteus is not being run as administrator unless the hex file is in your documents, it won't be able to open it. If you have downloaded the newest Arduino IDE it will be in program files(x86) and any sample will also be there. If you close Proteus and "Run as Administrator" it will be able to open the files..

If you have modified the schematic and you are running in free mode, it wont run it..

I tried to run proteus as administrator but it won't work.
And I am using proteus 8 professional so in that arduino ide is not required. Means the source code editor is in built in that.
 

RichTheDude

Active Member
Have you linked to the hex or elf file?

Double click on the ATMEGA (or right click, edit properties), click on the folder by program file and browse to your hex or elf file. Elf files are preferable as it enables debugging (i.e. viewing variables etc).
 

Rutvik Chauhan

New Member
I l
Have you linked to the hex or elf file?

Double click on the ATMEGA (or right click, edit properties), click on the folder by program file and browse to your hex or elf file. Elf files are preferable as it enables debugging (i.e. viewing variables etc).
I linked it. And I have tried for both .elf and .hex files.
When I run simulation at that time it shows could not load .elf file.
For knowledge if we can't link file than at that time it shows error : avr program property not defined.
 

Ian Rogers

User Extraordinaire
Forum Supporter
Most Helpful Member
If you are using the VSM code editor, try unchecking the "embed firmware" otherwise it gets placed too far away and the path doesn't work. I never use the embed firmware option for that same reason. The files will be in the correct directory after that.

Goto "Build/Project Options" and uncheck "Embed files"
 

Rutvik Chauhan

New Member
If you are using the VSM code editor, try unchecking the "embed firmware" otherwise it gets placed too far away and the path doesn't work. I never use the embed firmware option for that same reason. The files will be in the correct directory after that.

Goto "Build/Project Options" and uncheck "Embed files"
It is worked for me.
Thank you very much.
 

Rutvik Chauhan

New Member
Now I am using arduino ide and when I compile, the .hex file store in temp. In proteus when I use that file it shows error as shown earlier. Please if anyone has solution, give me.
 

Ian Rogers

User Extraordinaire
Forum Supporter
Most Helpful Member
First.. Where is the location of the file you need to load.

When I create a project I have a directory named the same as my project... I create a Proteus schematic and save it in that directory.
Then from the IDE ( in your case Arduino ) I save the code / sketch into the same directory... Then I attach the hex / elf in the micro properties within Isis... I can't show you as I don't have the Arduino model...
 

Rutvik Chauhan

New Member
I think my problem is solved. I change the location where the build files saved. But now the problem is when I compile it is completed first time. But when I compile second time at that time I got error. Also if I restart the arduino ide and then compile it is completed. So if there is any solution of this please give me.
 

Ian Rogers

User Extraordinaire
Forum Supporter
Most Helpful Member
I think my problem is solved. I change the location where the build files saved. But now the problem is when I compile it is completed first time. But when I compile second time at that time I got error. Also if I restart the arduino ide and then compile it is completed. So if there is any solution of this please give me.
Like I said before... You have admin rights problems... If Arduino IDE has admin rights it will read and save the file OK..

You need to read up on getting your applications administrator rights...
 

Rutvik Chauhan

New Member
Like I said before... You have admin rights problems... If Arduino IDE has admin rights it will read and save the file OK..

You need to read up on getting your applications administrator rights...
It has all admin rights. So I think it is not the problem.
And also it can read and write files earlier. But only the problem is it is written in temp directory.
 

be80be

Well-Known Member
The arduino Ide does not keep the hex it loads not by default if it's 1.8.4
There was a button in tools it's been removed
If you hit the verify button it will make one and save it on my computer it's
/tmp/arduino_cache_463758/core/core_arduino_avr_uno_fc271d69264b640f540ae730d6ca5643.a
you find where here the red text
Screenshot from 2018-01-05 05-04-37.png
Ok a little looking around and the 1.8.4 has the button moved to Sketch Called
Export compiled Binary
If you make a folder on your desktop blink hit the Export compiled Binary
and then open your folder you should have what you need.
Like this
Screenshot from 2018-01-05 05-18-35.png Screenshot from 2018-01-05 05-04-37.png
 
Last edited:
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top