• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

simple pic programmer problem!

Status
Not open for further replies.

Thunder_scream

New Member
...hmm I'm quite new in this area and I have a problem with a pic programmer that I got from the link given below .

http://www.circuitsonline.net/circuits/view.php?id=91

and I'm using a pic16f84-04 as the schematic suggests. To program the pic I've used the IC prog from "http://www.ic-prog.com/"

And my problem is when ever I try to burn my hex code in to the pic i get this error. Verify failed at address 0000h !

i'm kind of skeptical to the programmer as it is so simple...maybe it doesnt work..?? I dont know could anyone help me..
by the way i'm using winxp,amd 2000xp+

Thanks in before hand
 

Thunder_scream

New Member
Thanks mate the page was swedish but luckily I'm a swed so that was easily sorted... I tried the Picup programmer same thing it failed writing to the pic.

Could anyone perhaps suggest a very simple pic programmer with as few wires and componets as possible..that of course works...for pic16f84

I would be very thank ful if someone could help
 

Mullemeck

New Member
Try writing to your pic whitout the programmer cabel in it, you'll probably get the same error.

download this file
http://www.electro-tech-online.com/

place it in the same cataloge as ic-prog.exe and run ic-prog.
goto settings->options->Misc and check the box where it says "enable NT/200/xp Driver"
click ok and the program will restart and install the driver.

it could work
 

Thunder_scream

New Member
...already done..that...if i try without the cable in the serial port I get a different message "chip is copyprotected"....I'm trying with a different pic programmer...also from JMD hopefully this one does the job. if any one have a good pic schematic...could you plz posted here.

And by the way I can read the chip sucessfully...hmm i dont know if that says something.

Thanks for the help everyone.
 

Chippie

Member
I got to say that in all the time I've been programming pics, I've not had a problem.

I've used the JDM design with IC-Prog, no problem there.

I suggest you check that the mclr pin is raised to around 13v when in program mode, if it isnt then the pic aint gonna be programmed and you will get verify errors. Also check that Ic-prog is set to verify after programming..........
 

TronicBrain

Member
sorry Ms Mullemeck

But the link that you gave me is to the Home page of this site!!


and I would to say the I had the same problem again with JDM on icprog
 

Thunder_scream

New Member
could some´one tell me plz how i can check if my chip is working...i mean that it is not broken?

its a pic16f84

I think I did a stupied mistake...setting the chip upside down.. :lol:

one thing ...how do I check that mclr pin is raised to around 13v...that is mclr pin and what other pin?? and what can I do to raise the voltage?

tnx
 

Chippie

Member
pin 4 is the mclr pin, it hould have around 12-13v on it wrt to pin 5 (gnd) in program mode........the 12-13v is derived from the com port of your pc, look at the circuit, all will be revealed
 

Thunder_scream

New Member
you can't guess what was wrong.... :lol: ...one of the diod's was sitting upside down....heheh..now the *****sh***t works fine..hehe...

in case someone else makes the same mistake i post this pic here...hope its right.. :D
 

Attachments

Thunder_scream

New Member
yes I got the JDM 2 programmer to work and I burned the pic with ic-prog......

Now that I'm at it...is there a way connecting the servos to the rs232 ...i.e getting the power from the seriall port...cause that would be smother..right? But as I understood so far...the seriall port can oscillate..up and down in voltage...thus I need to have a fix 5v from it...how do I do that?

this is the controller I built (not my design though)...
 

Attachments

Mullemeck

New Member
i dont't think you should take 5v from your serial port, it might not be abel to deliver enough current to the servos.

instead take power from the PSU, It'll be easy too
 

TheAnimus

New Member
The ps2 port and game ports are a nice source of 5v according to one of the specifications they can take 250ma each, however you should check on the hardware you use, like the parport current, there are about 5 differn't current levels.
 

Erni

New Member
Failure: Programming failed at Code adress 0000h !

Hi! I'm trying to write on my PIC16F84A for 3 days. I'm using this shematic: -> "Programming failed at Code adress 0000h !"



The programmer i'm using is JDM. And I tried to burn with IC-PROG. Also tried with other but this one is the most comfortable i think.

oh i'm not using 78L05, i'm taking 5V from PC!

System:
Win XP -> Driver for IC-Prog already installed
5V, 12V, 0 all from PC -> 5.3 / 12.3 says the MBM5

Everytime IC-PROG tries to burn, MCLR gets 12V. I've checked this.

I really dont know whats wrong :(
plz help and i'm sorry for my bad english :), thx :!:
 
Status
Not open for further replies.

EE World Online Articles

Loading
Top