• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

SIM800 Module stops registering after a few days

Thread starter #1
I'm working in a project where I have a MEGA2560 and a SIM800 module.
I basically followed the guidelines in https://vsblogs.wordpress.com/2013/11/28/tcp-connection-over-gprs-using-sim900-and-at-commands/ to deal with the SIM800 module and the connection.

The thing is that everything works perfectly for a few days and then the module stops registering in the network. I replaced the SIM card for a new one and it starts working again and after a few days same problem. I get a registration denied error (AT+CREG? returns +CREG: 1,3).

I used 3 different SIM cards from 2 different phone companies with the same result.

What's weird is that if I install in my cellphone any of the SIM cards that are not registering with the SIM800 module, they register perfectly well and I can navigate the web with no problems at all. If i take them back to the module, they don't register.

Also, the weird thing is that the module is supposed to register on it's own at power up or reset without any intervention from my Arduino code. The module tries to register, I see the process if I monitor it via serial port from the PC but registration is denied over and over.

Any ideas?

The attachment shows the module I'm using



Well-Known Member
Have just got a Sim800L and am starting to test it out.

From looking on the web, it seems the 800 is 99% compatible with the 900 AT commands , but there are the odd differences, though did not make a note of them at the time.
Also very mixed comments on if the bare 800 boards do accept 5v TTL logic signals or if , as I have done, a divider should be used on its RX pin to bring the level down to 2.8v

When you say it works perfectly for a few days, do you mean continuously ?

What about the Sim800 chips temperature, is it overheating or a problem with its power supply at 3.8 to 4.2v ?

I'm using various sketches and ATCommander to test the module, when yours does not not register are you still able to do other basic functions ?
Thread starter #3
Thanks for your reply.

1) When I said continuously I meant exactly that. Since The software is still under development, right now the Arduino board receives information from different sensors and this information is then posted to a web service. At this moment this is done once a minute. Once in production the sampling frequency will be configurable although it most likely be at maximum once every couple hours.

2) The power supply is providing right now 3.9V. I tried different values from 3.7V to 4.0V. When the module tries over and over to register into the network it heats up a little bit, just like a cell phone heats up when you have heavy internet use. Not more than that.

3) When the module is not registering it does respond to every single AT command perfectly. You can do everything you should be able while not registered (at least everything I tested so far). Everything does seem to work right, it's just that the SIM does not register. If I put a new SIM card it registers and everything works back again.

It looks like if the network identifies the SIM card and rejects it for some reason. Maybe there's something I do that cell companies don't like so they kick me out. Weird thing is that if I install the SIM card in my cell phone it works with no problem.

Right now when I power up the module it just gives me +CREG: 1,3 if I just query the registration status, without even sending any other commands, so it's not in response to the commands my arduino code sends.


Well-Known Member
Is it a stolen or fake SIM800?

All GSM/GPRS modules have to tell the network their IMEI to work, and it could be that it takes a few days for the network to check the IMEI number against some database.

If it is a fake or copied module, their may be lots with the same IMEI, which will cause all sorts of problems when they try to register.
Thread starter #8
I tried today with 2 new SIM cards from 2 different companies (one of them I never tried before) and now I see the problem changed.

The registration is now denied right from the start.

I guess there's something wrong with the SIM800 module now. This is not the behavior I saw before.

Power supply is 0-30V 3A. I've been setting it from 3.8V to 4.1V.

The modem still responds to all AT commands. It does seem to heat up more than before.


Well-Known Member
There could be a problem with the power supply. It is possible that the modem has been damaged by the power supply.

If you look at this thread


you can see that powering a module with a remote power supply can be difficult. I assume that a 0-30 V power supply rated at 3 A is a bench power supply. The wires between that and the modem will have significant inductance, and the power supply may not respond well to the sharp increases of current.


Well-Known Member
While your main problem does sound like a network limitiation when used on the Sim800 module, how have you connected the Sim800L RX pin to the Megas TX pin, a direct wire ?

The spec sheet for the Sim800L on a bare module like these is 2.7v, so a potenial divider or similar is needed.

It does seem to work at 5v , but I did not keep it at that for long after I realised the sellers info of 'TTL compatible' is wrong for these modules ( not the larger 800L EVB modules ones which has logic level shifters)


I am facing similar problem. Few of my SIM 808 boards stopped registering the sim on network. They are in the field for few days (3 days to 30 days). I am totally clueless. I would appreciate any help on this.


New Member
I have same problem like Trilok, but with SIM800L modul. This moduls I was buy from China-Aliexp. and after normal work about 8-10 days boards stopped registering on network, board still work ok with AT commands. Sim card work ok in next (new) modul... (Also i was checked IMEI on http://www.imeipro.info/ and response is ok , it is not on black list...)
Please some help ?


New Member
Now I'm loose my patience and download some firmware for SIM800C module. After successful downloading firmware... it is same only difference is in status led, now led is all time off. One interesting thing is that receiving signal reading with at+csq is ok like in good module with same sim card... I think problem is in transmitter (inside module) maybe is good to go in sleep mode...


Well-Known Member
Most Helpful Member
I used 3 different SIM cards from 2 different phone companies with the same result.

What's weird is that if I install in my cellphone any of the SIM cards that are not registering with the SIM800 module, they register perfectly well and I can navigate the web with no problems at all. If i take them back to the module, they don't register.
My guess is that the cell phone company knows. I forst signed up with a cell company (cingular) thaat sold to AT&T. The Cingular plan was unlimited data. AT&T came along and started to charge for each breadcrumb.

So, when I want data on the phone, I have to pay for it. If I also want tethering (the real way), I have to pay for that separate.
When I went to a "smart phone" - It has a qwerty keyboard, my nice plan went down the drain.

The phone company knows, but it will take them a while to change the access or notify you that you need a different plan.

What sometimes works is to change the APN to the one the phone uses, not the one for data. They have different capabilities.


New Member
Now I have more info... after testing problematic SIM800L module (measure voltage on antenna out - with germainum diode....). Than compare with OK module, bad module don't have any voltage on ant. connector. OK module work fine when start -ON module or make call... voltage increase... Also I was talk with engineer from tel. company and he find that is all ok with imei and problem is in my module.


Well-Known Member
It sounds like the module wasn't made properly and it has failed after a few days. If the antenna isn't properly matched, you will get a bad VSWR, and more power than expected will be reflecting from the antenna, which can over-stress the transmitter.
Does the IMEI printed on the module correspond to the one that reads out electronically? The command for that is probably AT+CGSN.

You could check the IMEI number on http://www.imeipro.info/
HELLO I am using sim800l...
The imei printed on my board is different than as I get the imei number from AT+CGSN command.. What does it mean... My module is fake or something....?

And second thing my module stoped registering to network after couple of weeks... Before that it was working fine as required... And now I don't have another 2g sim for retest... And 4g sim also giving same result that is not registering...

Also firmware upgrade does not make any sense.. Same as not registering to network...

So.. Any one solved above problems...

Thanks in advance...

Latest threads

EE World Online Articles