• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

SARA R410M-02B-00 not registering to a network

Diver300

Well-Known Member
I've used several different Telit modules before, the GE863, GE864 and GE865, and I was wanting to move onto LTE. The ublox GPS receivers I've used have worked very well so I thought I would try the ublox cellular devices.

I've got an SARA R410M-02B-00 which I can't get to register to a network.

It's fitted to a Sparkfun Arduino shield but to start with I'm just typing AT commands by hand.

It's powering up, and responding to the AT commands. I can read the SIM number using AT+CCID?, turn it off with AT+CPWROFF, reboot with AT+CFUN=15 etc.

I've turned on the network light with AT+UGPIOC=16,2 but it never lights. The response to AT+CREG? is +CREG: 0,2. I've tried AT+COPS=? which eventually returns
+CME ERROR: operation not allowed

I get the same response with the two SIMs that I have tried. They are UK SIMS on giffgaff and EE.

Has anyone got any suggestions why it's not working?
 

Diver300

Well-Known Member
It's one of these:- https://www.sparkfun.com/products/14997

The circuit diagram is here:- https://cdn.sparkfun.com/assets/3/9/d/5/f/lte_cat_m1_shield_schematic.pdf

The 5 V supply is from a SMPS that I've been using with GE865s for ages, but for this I've tweaked it to 5 V. It's based on an LM25576. The 5 V that outputs is regulated down to 3.3 V within the Arduino shield with an AP7361C-33.

I've also got a fully charged 1.8 Ah Li-Ion battery attached.

I can't see any disturbance of the power supply, or any sign that any significant current is being taken.
 

Latest threads

EE World Online Articles

Loading

 
Top