1. Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.
    Dismiss Notice

Owon PDS 5022 S oscilloscope

Discussion in 'Repairing Electronics' started by Buzzman, Apr 15, 2018.

Tags:
  1. Buzzman

    Buzzman New Member

    Joined:
    Apr 15, 2018
    Messages:
    1
    Likes:
    0
    I have a 25MHz dual channel Owon PDS 5022 S oscilloscope that stop working. I've had it for about 2+ years. I used it for the first two to three months, and it worked fine. Then, I let it sit on the shelf in the house for the next 2 years. It was NOT exposed to temperature or humidity. Today, I decided to turn it on, and nothing happened. As you know, this unit has an optional battery pack for operating on straight DC battery power. My first thought was that I had forgotten to take out the batteries and corrosion was my problem. I open the back battery cover and found that I did not buy the optional battery pack for this unit.

    I have tested the power cord for voltage, and it checks out OK. You turn the unit on and approximately 20-30 seconds later you can hear a faint single "click" sound from inside the unit, and that is all it does, nothing else happens....no screen, no lights, nothing. I have moved the unit in different directions listening for something lose, and have heard nothing. I tried to open it up, but haven't been successful. There is a label on the back of the unit stating that there are no serviceable components inside. Does anyone have any ideas as to how a perfectly good running scope stops running because it was idle for 2 years?

    If you are wondering why it sat for 2+ years, is because I moved and I never unpacked it from the closet until today. I somewhat had forgotten about it.
     
  2. Little Ghostman

    Little Ghostman Well-Known Member Most Helpful Member

    Joined:
    Jan 7, 2011
    Messages:
    4,220
    Likes:
    484
    Location:
    SCOTLAND
    I can think of maybe two possibles, but keep in mind i love my boat anchor scopes and havnt owned a scope newer than 15 years old. It 'might' be something tiny like maybe a aux setting battery inside for the ram chips. If you can get a service manual look and see if it has an internal battery or better still a super cap. It could be that two years is enough to drain the ram/settings chips, so when your scope tries to do its thing it dosnt start because the info isnt there.

    Second one it could be is caps, caps tend to dry out or go bad quicker if you dont use something, i have often had to replace caps on the psu side of equipment if i havnt used it for a good while, but normally you get a iffy smell or smoke if thats the problem.

    So wild guess and its a wild guess, its a internal set up battery or super cap thats drained and the scope has lost its calibration data etc. But i dont know anything about these scopes. Look online, especially search EEV blog for tear downs, there is bound to be a tear down post of the scope somewhere or maybe even a video. Its worth the time finding out how to get it open without using a hammer.

    But hammers work 100% of the time for opening scopes if you use enough force. Duct tape sometimes gets them back together but often not :D
     
  3. KeepItSimpleStupid

    KeepItSimpleStupid Well-Known Member Most Helpful Member

    Joined:
    Oct 30, 2010
    Messages:
    10,096
    Likes:
    1,111
    I have a Tektronix scope that won;t work without good batteries. That's a possibility. It must have a good set of batteries.
     

Share This Page