• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Oshonsoft USB Demo1 Project

#21
hello once again, I´m sending the print screen of my configuration such as the result of ussing snoopy pro hope you can help me finding what I have missed. I´m also sending to you as you asked for my .bas file so you can try it the only changes I made were on the LCD configuration, wich by now is working :D and it only displays "USB Demo1." when I conect the USB cable, I alredy Cheked my usb cable and everything is ok. so still I´m in trouble... :( thanks for your help
 

ericgibbs

Well-Known Member
Most Helpful Member
Thread starter #22
hi jose
Downloaded your files, will look them over and I will reply tomorrow.

Did the Snoopy show the USB HID1234 as being present and active on your PC.??
 

ericgibbs

Well-Known Member
Most Helpful Member
Thread starter #24
no the Snoopy did not show de PID 1234
hi jose,
Its important that the Oshonsoft HID appears in the USB snoopy listing, else its not installed and the Oshonsoft programs will not work.

Recheck your Oshonsoft USB option installation.

Your Basic program looks OK.

E.
 
#26
I think my problem is on installing the usb terminal... can u help me with these part? I alredy checked de oshonsoft and i have the USB suport Enable
thanks for your help and time again
 

ericgibbs

Well-Known Member
Most Helpful Member
Thread starter #27
I think my problem is on installing the usb terminal... can u help me with these part? I alredy checked de oshonsoft and i have the USB suport Enable
thanks for your help and time again
hi,
Have you tried this link for the USB zip testing programs.?
http://www.oshonsoft.com/pic18usbsupport.html

I would suggest you send a request to 'Vladimir Soso' of Oshonsoft for an explanation why the USB is not working.
 
#29
Hi - I know this thread is old but I found this in a trawl through Google and am hoping you can help please - I have tried the USB_Demo3.bas (=USB_Demo2.bas) in the Oshonsoft PIC18 Sim IDE ver 2.82 and have recompiled USB_Teminal2F in VB6, but I cannot get the Simulator to get past USBStart. USB_terminal2F reports "HID connection failed!" and Oshonsoft HIDterminal reports HID (VendorID:1234;ProductID:1234) not detected or could not be accessed... The PC does not recognise a HID device to be present

I have two questions:
1) I am expecting the Simulator to Simulate a USB device - ie. I do not have a real PIC device present on the USB - is this a reasonable/correct assumption?
2) Is it possible the hidterm.ocx only works for VB5 - I have registered it and this was accepted OK?

TIA
Peter
 

ericgibbs

Well-Known Member
Most Helpful Member
Thread starter #30
I have two questions:
1) I am expecting the Simulator to Simulate a USB device - ie. I do not have a real PIC device present on the USB - is this a reasonable/correct assumption?
2) Is it possible the hidterm.ocx only works for VB5 - I have registered it and this was accepted OK?
TIA

hi Peter,
A working PCB having a PIC 18F2550 or similar PIC with inbuilt USB that has been programmed using the Oshonsoft IDE with the USB option is required.

The USB-demo uses the USB port of the PC which has the Oshonsoft hidterm installed.

The demo has been tried successfully on a number of projects.

What exactly is your set up regarding the hardware and software and what is your PC's operating software.?

Eric
 
#32
Thank you for your prompt reply - I suppose I was hoping the Simulator would Simulate a USB device. I do have a real device - 18F4550 running my PicBasic 2.46 program without a problem, and talking to the PC (Windows XP), with a VB6 program I wrote, and all was well until recently when the EEPROM was corrupted - my fault because I am using Interrupts and I read that the define WRITE_INT 1 protected WRITE from corruption by interrupts, but failed to see that this only applied to PBP >=2.50. This led me to test it out in software on the Simulator but I was unable to test the USB properly - Now I understand why - to be fair to Vladimir, the website does talk about hardware, but it is a case of the mind seeing what it wants to (rather like the WRITE_INT issue). Thank you for clarifying - so to confirm, the USB Support I paid for was actually only in the Basic Compiler (which I don't use - preferring PBP) not in the Simulator?
Peter
 
#33
hi,
Check your USB devices.

Use Start/Settings/Control/System/Hardware/Device Manager.

This is an image of my settings.

This is the dll, [ remove the .txt extension, I have to add that to upload].

Post your program I will try it.

Please upload the DLL once again, It is not available in the posting

Thanks
vinaiks

Dear Eric, I know now you are online, Please upload the HidTerm.Dll file
 
Last edited:

Latest threads

EE World Online Articles

Loading

 
Top