• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Oscilloscope repair

Status
Not open for further replies.

rfxcasey

New Member
My problem is I traded a friend some paintball gear for a Goldstar scope that he bought new and never really used. I didn't really have the space where I was living at the time to set it up so it sat for a couple of years. When I finally moved I started setting up shop and the scope worked great. I had a workbench out in my garage and I put the scope out there which was probably a bad idea as it gets pretty dirty out there with me cutting wood and grinding metal all the time. The scope sat unused on my bench for a little while and before using it again I was afraid some metal shavings or wood dusty might have gotten into the scope so I took off the cover and blew it out with the air from my compressor. It was unplugged when I did this. I let it sit for a little so any possible moisture would evaporate and then tested it out and the scope worked fine. The next time I went to power it up however the power led came on but I get nothing on the display, no traces at all. I have fiddled with all the controls and powered it on and off several times but nothing. With the cover off, when I power it up I can see some of the little tubes/diodes inside light up for a split second when I hit the power button, but then they go out. Any help would be greatly appreciated as it is not an old scope and is otherwise in brand new condition. It is analog not digital and I will post the exact model when I get home tonight. If I need to start a new thread, which I probably should have, I will, but I just need someone to point me in the direction of someone who can help. I would hate to junkt this otherwise great 300Mhz scope.
 
Last edited:

user_88

Member
Just a wild guess ... see if you can locate the main power supply section of the scope.
There should be a reasonably large power transformer someplace in the vicinity ... There will be several ... a number of secondary take-off wires, and fewer ... one ...two wires on the primary side. .... Make a careful inspection .... try to locate anything that looks like a fuse .... in this area of the chassis. .... or any place else.
... Also look for any obvious problems such as burned components .... melted wires.

In the event that you don't find anything that requires fixing, you should think about getting a schematic diagram for you scope. You might have to pay something for it, but it would be a worthwhile investment ..... as far as tracing down a problem or malfunction.
 

shimniok

Member
I think we can step you through troubleshooting the scope. The other thread, I think, has a link to a Tektronix troubleshooting guide that is excellent. I am not a guru with the circuit level electronics but can at least get us to the point of knowing which section the problem is in.

After you reply to the 2nd post (above) then I'll make some troubleshooting suggestions if needed.

Michael
 

rfxcasey

New Member
OK I have the model number it's a 0S 9040D 40Mhz. I thought it was a higher frequency scope but I was mistaken. Still it is practically brand new and worth fixing. I haven't had the chance to crack it open. I probably will tonight.

So are you saying that there will be additional fuses beside the main fuse on the back of the unit? Great suggestions by the way. I believe I have the book for it somewhere but I will have to track it down when I get the chance.
 

rfxcasey

New Member
Holy cow, I opened up my scope and was checking around like you said. I saw what I think would be that fuse you mentioned and it was right where you said it would be. Funny thing is it checked out ok with a multimeter. So I checked the rear fuse again and that was good. So I looked around for some culprit but nothing jumped out at me. I did see on little tube like glass bulb on the edge of the pcb that looked like it might actually make contact with the side of the case so I ever so gently moved it. I don't know if that did anything but when I turned the scope on it was like BLAM! channel one trace and BLAM! channel 2 trace. I turned it off and back on again about 3 times giving it a few seconds in between and I still have full functionality. I guess that darn thing works after all. I am just wondering how long this will hold out for? I never even got a chance to use the scope so I hope it's fixed for good now. Knowing me though something will go wrong, but maybe this time I will be spared.:):):):):):):):):):):):):D:p
 
Last edited:

user_88

Member
It may be that the fuse holder is not making good contact with the fuse.
Just unplug the power cord, and carefully remove the fuse, and then clean the metal fuse holder.
It's a good idea to use an electrical contact cleaner spray ... This will remove any grease or non-conductive material ... Maybe scrape the actual contact point of the holder with something abrasive .... The idea is to have good metal to metal contact .... no oxidation, oil, grease, rust ......
 

rfxcasey

New Member
Well the internal fuse is hardwired in so your theory won't apply to that. The rear external (for lack of a better term) fuse didn't seem dirty or corroded. The unit was getting power just no trace. I had backlight ilumnination as well, just no traces. Messing with the focus and intensity did nothing nor did the positioning. I am wondering if there might have been some residual moisture int he thing or a stuck relay from sitting too long. One thing is for sure, it's saying in the house from now on instead of the garage. I tried everything before to get a trace but there was not joy. Now I have joy.:p
 
Last edited:

user_88

Member
... Your problem may be related to an electrolytic capacitor. These parts are known to age .... something to do with the dielectric material between the metal electrodes. Sometimes you can just apply power to the unit for a while, and the capacitors will 'come back to life' .....
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top