• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Not able to flash code in ESP32

Derby

New Member
Hi, I was giving a try to the new esp32 board but while flashing code through Arduino ide, Although I did install ESP32 USB drivers and tried to press boot button to flash but still not able to flash the code in windows OS, in MAC OS it's working fine

Any suggestion on this will be a great help.
 

gophert

Well-Known Member
Most Helpful Member
Did you select the exact ESP32 board that you are using?
Does your board have usb connector or do you have a serial adapter cable?
 

dr pepper

Well-Known Member
Most Helpful Member
Esp8266 type #1 needs a pin grounding to put it in program board, if thats what your using.
 

Pommie

Well-Known Member
Most Helpful Member
Flashing normally refers to rewritting the firmware. Why do you need to do that? Or, do you mean compiling a sketch?

Mike.
 

ClydeCrashKop

Well-Known Member
Most Helpful Member
I may be wrong here, but try holding the button until a light comes on.
 

Derby

New Member
Hi, I have tried the process of holding the boot button while uploading code through Arduino and then press the reset button while connecting process starts but still the same problem.
Note: I am using USB connector is available I am trying access through this only.
 

dr pepper

Well-Known Member
Most Helpful Member
yup sorry, a little number dyslexic.
I was thinking esp8266.
 

Latest threads

EE World Online Articles

Loading

 
Top