• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Help with ECU reference voltages

max1

New Member
HI, I am having problems with a no start Peugeot 207, here is a summary - https://www.peugeotforums.com/forums/207-36/non-starter-336542/#post2240902

Am just trying to rule this out but I have a 3.3V at the ECT sensor reference (sensor unplugged) rather than 5V & not sure if this is correct. The diagnostics software does show the engine coolant temp at around 10c however which seems accurate. All other sensors I can access have 5V on them. ECU is a Bosch MEV17 the car is a Peugeot 207 1.4 Vti 2009. I know some processors run on 3.3V but not sure in this case so was wondering if anyone recognizes or can verify it?


thanks for any help
 
Last edited:

max1

New Member
If anyone has even vaguely heard of 3.3v being used in a vehicle in this way then id be very grateful to know? Thanks
 

KeepItSimpleStupid

Well-Known Member
Most Helpful Member
3.3 is a suspicious number so it's likely.

FYI: The reference voltages are not 3.3 and 5V, but rather the supply voltage. They are the nominal values. It could be 4.95 or 5.12 at the tim the measurement is taken and they become the reference voltages. It's called a relative reference.

1/2 the supply voltage is generally another reference. It comes about because OV and 5V are not achievable in practice. You can get close, but not to the rails.
 

max1

New Member
3.3 is a suspicious number so it's likely.

FYI: The reference voltages are not 3.3 and 5V, but rather the supply voltage. They are the nominal values. It could be 4.95 or 5.12 at the tim the measurement is taken and they become the reference voltages. It's called a relative reference.

1/2 the supply voltage is generally another reference. It comes about because OV and 5V are not achievable in practice. You can get close, but not to the rails.
Thanks for this much appreciated. Sorry, I assume you mean that 3.3V is likely to be wrong & therefore treat it as suspicious ?
 

narkeleptk

New Member
I see 12v, 5v and 3.3v in many ecm's here in the U.S but the 3.3v is usually for the mcu. Seems a bit odd that all the other sensors are around 5v and he is 3.3v but its possible I suppose.
 

Latest threads

EE World Online Articles

Loading

 
Top