Continue to Site

Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Hall effect current sensor - from Allen Bradley Powerflex 755 - please help to identify

niroby

New Member
Good day everyone,

I've been trying to repair VFD from Rockwell / Allen Bradley - Powerflex 750 series - model number 22C-D045A103 - series A. Initially, we were having troubles with Fault 13 (Ground Fault) being displayed at random. After extensive troubleshooting we've managed to narrow it down to one of built-in current sensors being faulty.

Unfortunately, the sensor itself does not have any marking printed. I've tried to open one up, but internal marking was not much better -at least I could not identify the component. I tried to look through DigiKey website in attempt to recognize the shape/appearance - again, none was matching.

I managed to find an identical/similar board on AliExpress, but my worry is that it could suffer the same issue as our ones. What I've learned from Internet this fault was pretty comon back some time, so the chance are high. So I would like to try and source the components for the repair rather than relying on luck to get 100% working used board.

Below, I've attached some pictures of the component and current sensing board assembly. Have anyone come across such a critter? Any suggestions or leads will be greatly appreciated

Thanks in advance
 

Attachments

  • IMG_20230701_130811259_HDR.jpg
    IMG_20230701_130811259_HDR.jpg
    3.8 MB · Views: 160
  • IMG_20230701_131549246_HDR.jpg
    IMG_20230701_131549246_HDR.jpg
    4.6 MB · Views: 165
  • IMG_20230701_134909306.jpg
    IMG_20230701_134909306.jpg
    2.6 MB · Views: 164
  • IMG_20230701_162706267.jpg
    IMG_20230701_162706267.jpg
    1.6 MB · Views: 157
  • IMG_20230701_163329081.jpg
    IMG_20230701_163329081.jpg
    1.8 MB · Views: 158
  • s-l1600.jpg
    s-l1600.jpg
    155.9 KB · Views: 159
I'd try re-soldering the hall device in the unit - the four points at the top centre of the PCB?

Two of those joints look like the may be dodgy!
 

Latest threads

Back
Top