• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

counters in circuit software

Status
Not open for further replies.

daviddoria

New Member
i am using Trax Maker to draw. I noticed that on my 4017, there is no pin 8 and no pin 16. these are Vs and ground. when i hit "simulate" it doesn't work (i'm guessing because the chip isn't getting power)

i also noticed on a drawing by kinaljp that he was missing the same pins...
is there a way to add pins? are they left off for a reason?

ADDED * a buddy of mine said that these pins are assumed by the software. any truth in this?

david
 

kinjalgp

Active Member
In digital simultion, Vdd, Vcc, Vss and GND are assumed by the software. You normally don't require to explicitely connect these pins to supply rails.
 

daviddoria

New Member
hmmm... then i wonder what is wrong with my circuit.. it works in real life hehe... it says "some components may not simulate" then it highlights capacitors and ICs.

this is the circuit maker that comes with TRAXX Maker

anyone use this that i can send my file?

david
 

kinjalgp

Active Member
I know why it doesn't work! The error is caused because your simulation mode is set to analog mode, change it to digital mode from the menus.
 

kinjalgp

Active Member
Opps...I told you the other way round, in Digital Mode, it is not possible to simulate capacitors and other passive components in Circuit Maker.
 

Gene

New Member
David, Here's an idea - There is a buffering action at the output pins of the IC which reduces the current flow. If your circuit (on paper) has an LED and a limiting resistor in series feeding from the output, the output voltage of the IC may be below the cut-off for the LED.

Try this - If your simulation software has a voltmeter or (better yet) an oscilliscope, connect it (on paper) to an output pin and see what you get. If you are powering the IC with 9 volts, the simulation sees 2 volts at the output and probably has set the LED cut-off at 2.1 or 2.2 volts (e.g., not enough to turn on the LED in the simulation). If your software does not have this feature, try connecting the LED directly to the output pin (without the limiting resistor) - bet it will work now.

Do not change your real circuit if it is working properly (I didn't really have to say that - did I?)
 
Status
Not open for further replies.

EE World Online Articles

Loading
Top