Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Converting a dead LCD 240 x 96 display to video out? Is this possible?

Magistro12

New Member
Hello,
I've got a question I've researched high and low but can't find a solid answer to. I've got a Roland Juno G synthesizer. They're notorious for failing LCD displays. Mine has failed but it's nearly impossible to find a replacement. Without a display the synth is seriously handicapped. Its not possible to live control with a PC so it def needs some kind of display.

Aside from trying to restore the original LCD, is is possible to somehow either add a "ribbon output" of sorts, similar to a video out to drive an external LCD display? Forgive me if I'm over simplifying a complex request, but many owners of this Synth have tried to find solutions to this common issue without success.

So to summarize, I would like to either add an output to this synth allowing me to connect to an external lcd display similar to what was originally in the synth so it would just be a matter of matching ribbon connections,
OR
I'd like to add some kind of composite output to the juno in place of its failed LCD so I can view the display on a TV or monitor.
Honestly, even if the quality of the display i can get to work is not perfect, it will allow me to use the menus and other features from this synthesizer. I'm not concerned about a screen that fits into the synth and I'm fine with something functional that's not pretty.

The information on the back of the Juno G display is as follows;
5485SGPABNC 0906-4T
V0054850 Rev A

Please also see the included diagram info from Roland.

Thank you for any help you can offer!
 

Attachments

  • Screenshot_20220807-213745_Chrome.jpg
    Screenshot_20220807-213745_Chrome.jpg
    182.5 KB · Views: 47
  • Screenshot_20220807-213748_Chrome.jpg
    Screenshot_20220807-213748_Chrome.jpg
    44.6 KB · Views: 44
  • 20220807_164704.jpg
    20220807_164704.jpg
    953.9 KB · Views: 45
  • 20220807_164709.jpg
    20220807_164709.jpg
    1.1 MB · Views: 45

rjenkinsgb

Well-Known Member
Most Helpful Member
The connection to the screen is an 8 bit microprocessor data bus; the screen is effectively a computer peripheral and the "video" pixel information is created by the display controller IC within the LCD assembly.

It's an odd size display and there is no fixed standard I can find for the addressing or chip select lines - there are some displays with the right pixel format but connecting one up and getting it working will involve some serious trial and error.


or these:

The power, ground and data bus lines D0-D7 should be straightforward, also the register select (RS) and write enable (WE).

The chip select lines are the tricky part - there are just two from the synth, but apparently four used in the LCD. It may need a 2:4 decoder IC & some other bits of logic adding and that may relate to the different firmware updates required for different generations of Roland replacements?

There is a post half way down this page with a download link for the 2.01 firmware:


Note that several people have found the display fault to just be bad connections on the various plug-in interconnect cables and fixed it by treating everything with switch cleaner.

Another one here relating to the fixed ribbon cables on the back of the screen:

I had a similar display problem. My Juno-G was already once fixed and the display was replaced, and after a year the new display broke again same way as before. I opened it and noticed that it has something to do with the two ribbon cables that are not getting contact in the display unit. I warmed the ribbons gently with a soldering iron from points where they are connected to the display’s component side board. This helped for now.
At least now it has worked for some time. I guess they make some mistake in manufacturing process when attaching those cables as so many similar cases have appeared.
75e893e68b373d85a85550deac44ac23
Comment by Raimo Ontero | March 27, 2012 | Reply
  • This is the ONLY solution which works, right!
    I’ve done it in the same way, and used desoldering-wire between the strip and the soldering-tip. My temparature was about 310°C for best results. It’s done in aprox 30 minutes.
 

Magistro12

New Member
Thank you so much for that detailed information! I've had the entire unit apart and cleaned all ribbon contacts woth no success, but the trick about heating the connections on the back of the lcd was not something I've tried yet! I'm excited to give that a go and with any luck I'll be able to avoid a major headache. Thank you again for your help!
 

Magistro12

New Member
Hello, I've removed the LCD screen and heated the two side ribbons as specified in the post above. When I turn on the unit I still have LCD issues but I've been able to isolate the issue to the ribbon in the center. Unfortunately it seems to be covered in epoxy and I'm just wondering how to go about reflowing that area?
Thanks in advance!
16600744754954057947015043132379.jpg
 

Latest threads

Top