Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

problem in keil 5

tariq70

New Member
hi everyone

I'm using keil 5 for stm32 i have problems fist while building my project some black window comes i attached their pictures.

second when i want to load my project i have this error :



ERROR:Flash Download failed - could not load file

'C:\Users\..............'



when i delete keil and install it again The problem solves but after few days i have the error again.i dont know what is wrong with it.

i'm also using stmcubemx to tranfer data to keil.
appreciate your help.
 

Attachments

  • 1.png
    1.png
    322.4 KB · Views: 21
  • 2.png
    2.png
    204.4 KB · Views: 21

MacIntoshCZ

Active Member
I would say it does not recognise vendor ID so maybe flasher unit is clone or faulty?? But if it sometimes work and sometimes not, its sounds like problem with synchronisation...
Or drivers are faulty.
Or yours software is wrongly set.
Since i dont use ARM processor i cant help more
 

Latest threads

EE World Online Articles

Loading
Top