Welcome to our site!

Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

  • Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

PIC 16f690

Status
Not open for further replies.

GaryPhy

New Member
i am learning to use PICs, so i have a question on how to add Header files in the project such as the p16f690.inc. Can anyone help?
 

Smartie

Member
Assuming you're learning Assembly, at the top of your ASM file add:
Code:
include "P16f690.inc"
 

ericgibbs

Well-Known Member
Most Helpful Member
i am learning to use PICs, so i have a question on how to add Header files in the project such as the p16f690.inc. Can anyone help?

hi Gary,
On your hard drive, if you used the MPLAB IDE you should find this Folder, all the headers are there.
C:\Program Files\Microchip\MPASM Suite\Template\Code

This attachment is for the 690
 

Attachments

  • 16F690TEMP.ASM
    4.7 KB · Views: 122
Last edited:

Smartie

Member
I had a search around in my microchip folder and found all the .inc files are stored under "C:\Program Files\Microchip\MPASM Suite"
Try including that in your project build directories and see if that works.
 

GaryPhy

New Member
how do i get it to look like pic not pic1
 

Attachments

  • pic.jpg
    pic.jpg
    81.8 KB · Views: 172
  • pic1.jpg
    pic1.jpg
    175 KB · Views: 165

ericgibbs

Well-Known Member
Most Helpful Member
Hi,
Which programming language are you using to write the programs.?

Is it HITECH C or assemmbler.?
 

Smartie

Member
You don't use HiTech c for assembly, you use that for writing code in c.
If you want to program in assembly follow these steps:
1) In MPLabClick on Project -> "Select Language Toolsuite"
2) in the new window, choose "Microchip MPASM Toolsuite" from "Active Toolsuite"
3) Click "ok" and try to build again
 
Status
Not open for further replies.

Latest threads

Top