• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

MPLAB 820 linker issue

Status
Not open for further replies.

geko

Active Member
For some reason it appears that in MPLAB 8.20/a when you use the quickbuild option without a project it's now invoking the linker.

It's not done this in any previous versions that I'm aware of and now with 8.20 the linker falls over on the the fill command in this bit of test code. If you quickbuild it using MPLAB 8.15a it assembles fine.

Code:
 list      p=12F683
 #include <P12F683.inc>  
 
 __CONFIG    _CP_OFF & _CPD_OFF & _BOD_ON & _PWRTE_ON & _WDT_OFF & _INTRC_OSC_NOCLKOUT & _MCLRE_ON & _FCMEN_OFF & _IESO_OFF
 
 org 0x000
 nop
 nop
 
 fill (nop), 0x7FF-$
 end
Without getting into the whole relocatable/reusable code argument I don't really understand why the linker is being invoked when the Quickbuild is being run outside of a project.

Is this a just happening to me or is it a 'feature' thats wound up in the latest release of MPLAB and if so anyone know a work around short of going back to 8.15?
 
Last edited:

geko

Active Member
Why not just set it as a project?.
It's a fair point.

It was much easier to tell people to open a file in MPLAB, select project and quickbuild - job done and that's what I've done for the projects on my website.

In versions of MPLAB up to and including 8.15 that's worked, now in 8.20 it runs the linker and there seems no way to change that behaviour.

Guess maybe I'll have to start doing my PIC projects as projects:)
 

be80be

Well-Known Member
Are you using Vista I can't quickbuild any thing on my kids vista but the computer i use in my shop I can it has xp pro and after reading some of this post I was looking the Vista didn't let mplab install the same files as Xp
 

geko

Active Member
Are you using Vista I can't quickbuild any thing on my kids vista but the computer i use in my shop I can it has xp pro and after reading some of this post I was looking the Vista didn't let mplab install the same files as Xp
I'm using it with XP, it's the same on three different computers with 8.20 but the forth one I use is still running 8.15a. MPLAB works okay on all of them with the exception of the quickbuild under 8.20
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top