• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

More Cascading LM3914 questions...

Status
Not open for further replies.

tvsound

New Member
Hi,

Having played around a bit more with 1 of these cascading into another I have the following problem which for the life of me I CANNOT FIX!!!

First of all...assume I have plugged these up as shown on the datasheet.
Second...assume I have plugged these up as shown on the datasheet.

The scenario is that I am feeding these a "signal" which varies between 1.25V and 0V and I want the two cascading LM3914's to act a a voltmeter as the signal goes from high to low and vice versa.

I am taking the reference voltage (1.25V) out of "chip 1" and feeding it back into Ref-Hi of chip 1. I am also passing it across 2 equal value resistors and then to earth to form a simple voltage divider. I am taking a feed from between the 2 resistors (0.625V) and sending it to Ref-Lo of chip 1 and Ref-Hi of chip 2 and am connecting Ref-Lo of chip 2 to earth.

The circuit appears to behave itself very well...ie the led's illuminate in accordance to the input voltage and track up and down the scale in a linear fashion.

HOWEVER....if the input signal is above Ref-Hi of the second LM3914 (0.625V) then LED No.10 of that chip (pin 10) is always illuminated.

SO...whenever the signal is above 0.625V and LM3914 No.1 is illuminating the "correct" LED I have LED No.10 on LM3914 No.2 illuninated as well.

If the signal falls below 0.625V then LM3914 No.1 stops illuminating any LEDs (as expected) and LM3914 No.2 behaves itself...ie the LED's track up and down as the signal goes between 0.625V and 0V and LED No. 10 goes out when it's suppose to.

So...assuming I have plugged these up as shown on the datasheet....

Has anyone come across this before?
Am I doing something silly?...ie, have you plugged this up accoring to the datasheet and found that it works fine???
Or...if you've got a simple circuit diagram of how you'd do this please feel free to post it!!!!!

Kind Regards,
TVS
 

duffy

Well-Known Member
Did you tie pin 1 on the second chip to the mode control bit on the first chip?
 

tvsound

New Member
Yes...Pin 1 of the second LM3914 is connected to PIN 9 (Mode) of the first LM3914...these are also connected to the cathode of LED No. 11 (the first LED of the second LM3914)
 

ericgibbs

Well-Known Member
Most Helpful Member
Yes...Pin 1 of the second LM3914 is connected to PIN 9 (Mode) of the first LM3914...these are also connected to the cathode of LED No. 11 (the first LED of the second LM3914)
hi tvs,
Is it the cct on page 9 of the LM3914 datasheet.?
 

chemelec

Well-Known Member
Yes...to the best of my knowledge I have copied the circuit from page 9 of the LM3914 datasheet
1) Did you use a "Common Point Ground" for Each LM3914?
This help Prevent Ground Loops.

2) And Did you place a 20K resistor Between V+ and Pin 11 of the First LM3914?
This should Stop LED 10 fro staying lit.

Gary
 

tvsound

New Member
Hi,

Thanks for your reply.

Yes...grounds tied together and 20K resistor makes no difference
Kind Regards,
TVS
 

chemelec

Well-Known Member
Hi,

Thanks for your reply.

Yes...grounds tied together and 20K resistor makes no difference
Kind Regards,
TVS
That is NOT what I mean.

I Said a COMMON "POINT" GROUND.
In a Common Point Ground, There are "No Voltage Drops".

This is Different than a Wire Joining all grounds Together.
In This Ground, there are "MANY Voltage Differences between All connections".
The LM3914 is Sensitive to Very Low voltage Differences, ESPECIALLY When you Cascade them.



This Common Point Ground is also Important when designing Circuit Boards for Audio Power Amplifier, "Especially the Integrated Circuits ones".
The voltage Drops may be in the Micro-Volts, but that can cause Oscillations is such Sensitive Circuits.
 
Last edited:

tvsound

New Member
Tried common point ground and unfortunately it has no difference...meter across ground points shows no potential difference....perhaps I'm just making a silly mistake when constructing this???

Has anyone else tried building the circuit on page 9 of the LM3914 data sheet and had any success?????????????

TVS
 
Last edited:

duffy

Well-Known Member
I built one years ago with 20 segments. Don't remember a problem... but it was 20 years ago. Sure your chip's ok? Tried swapping chips?
 
Last edited:

chemelec

Well-Known Member
Tried common point ground and unfortunately it has no difference...meter across ground points shows no potential difference....perhaps I'm just making a silly mistake when constructing this???

Has anyone else tried building the circuit on page 9 of the LM3914 data sheet and had any success?????????????

TVS
Yes it Works.
And I have made one with 4 cascaded sections.

It is Unlikely you will measure these TINY Voltage drops across the Grounds.
You Need a Nano-volt or Fempto-volt Meter for that.
 
Last edited:

tvsound

New Member
I must be making a mistake when I'm building it then.
I'll start from the beginning again today and see if I have any success!

TVS
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top