• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

keyboard problems Acer Aspire One netbook

Status
Not open for further replies.

Vizier87

Active Member
Hi guys,

My netbook's keyboard suddenly stopped functioning, but it IS detected in the hardware section with the exclamation mark. I tried everything, from rebooting and tried to update the driver but it seemed that there is no update (of course, why should we update keyboard drivers? :() I'm not willing to reformat yet, there has been so much updates which made my netbook really at par with others. The hardware profile showed "code 10: the device cannot start"

Is it possibly a virus or do I have to replace the keyboard? I'm using my sister's lappy for now.

Many thanks.
 
Last edited:

ismith1984

New Member
two questions...what is the operating system you're currently using and secondly what message do you get when you ccheck the status of the keyboard under properties "device status" under properties. if it does show an exclamation mark you should see an error code. what is that error codehttp://www.electro-tech-online.com/newreply.php?p=875129&noquote=1
 

ismith1984

New Member
ok sorry guy for not responding so soon. your problem could be a number of things it could be that you keyboard is defective ( unlikely), it could be that some spam or something to that effect has corrupted you registry. there are ways you could check but i recommend that you just run a repair if you are using windows xp. that way you windows files are fixed and at the same time you registry is also repaired. dont know how you get that done on your particular netbook but i am assuming that it can be done since you said the xp was built in.
 

Vizier87

Active Member
well... problem solved. I think it is a registry problem. I uninstalled and reinstalled the keyboard a few times and rebooted until it worked again. hard to explain what going on there though.
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top