• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Invalid device signature with avrdude

Status
Not open for further replies.

savvej

Member
I am facing some unusual problems since morning while using USBASP to program atmega 32.
First and foremost ,out the the several times I tried to program,at most occasions either the device signature was invalid or there was verification error.After quite some tries,finally my code(around 8000 bytes) got burned into the uC(with each programming trial taking around a min and half due to the large size of the code :( ) .Latter when I was debugging my code on the hyper terminal(i.e. I was using serial interrupt to display values of various variables I wanted),I was getting lot of garbage characters many times.As time passed after around 1hr everything was working OK excepting that I wasn't getting perfect reception(though I used to get perfect reception previously).
I was using internal clock frequency of 8Mhz and 19200 baud rate for serial communication.
after around an hour,when I again stated debugging code, I started getting all garbage values .I thought that there must be some error in baud rate setting.When I checked the fuse settings I saw that they had got automatically changed.Instead of 8Mhz clock it was 4Mhz setting and also SUT bits and BODEN bits had also changed.I changed the fuse bits settings to E4 and D9 low and high bytes receptively as according to my requirement.Now I was getting almost correct reception.I wanted perfect reception,as it should be,so I started googling.And found that the internal oscillator frequency depends on supply voltage and frequency and from avr documentation on "avr 8002",came to know that we can calibrate it using OSCAL register and some reference input.I didnt change any calibration settings but for info my CALIBRATION byte read A6A6A6A7.

I was powering my uC from a mobile phone adapter rated 5V 500mA(Samsung Champ Charger).So to eliminate variations in power supply if any I made 7805 circuit on board and changed to that supply.I read fuse bytes and they read correctly.after that I programmed uC but I got verification error.I resetted uC and power supply as well as disconnected and connected programmer back to laptop.I again tried to read fuse bytes but just then a wire came off the programmer.I got programming error and then when I again tried to program I wasn't able to program it till now since 2hrs.

Is there any way to check if my uC dead or alive?or can I revive it/has my fuse settings got changed again?Or has anyone encountered such a problem previously?How do I proceed further?I tried using my friends programmer it doesn't work with that either.

Now when I program using avrdude I am again getting any device signature like 00ff00.
0f0ff0,0f0f7,01ff0 etc.And it says 'Yikes invalid device signature'.
Please help me debug this problem.Please.
 
Status
Not open for further replies.

EE World Online Articles

Loading

 
Top