• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

ic-prog problems

Status
Not open for further replies.

SianZ

New Member
I am using jdm programmers, from the website settings, it says i should switch to direct I/O instead of windows API. But however when on Direct I/O there is no voltage change on my serial port. But there is on windows API. Regardless both settings i am unable to program my pic (000h fail)
 

Thunder_scream

New Member
if you have winxp....?? then you must download the extra driver for ...ic-prog.. just look for it in their...page..its there trust me.

and check so that you havent accidently put one of you diods reverse...(thats what i did once..hehe)
 

TheAnimus

New Member
the problem is that an NT based OS all code runs in RING 3, this means when the CPU comes to try and use an OUT instruction with an address like the parrallel port it can't access it.

There are ways of getting round this, some ways better than others.
see beyondlogic's parrallel section
www.beyondlogic.org
 

SianZ

New Member
Thunder_scream said:
if you have winxp....?? then you must download the extra driver for ...ic-prog.. just look for it in their...page..its there trust me.

and check so that you havent accidently put one of you diods reverse...(thats what i did once..hehe)
I am using win xp i also did downlaod the driver but the problem still happens
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top