• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

help needed in lcd module interfacing

Status
Not open for further replies.

tariq7868

New Member
Hello.. I am really new to microcontrollers & LCDs. I m trying to implent a simplest circuit which in using 8051 a text is displayed on 16 x2 lcd module. u can view the schematic and hex file in the attached files.. and also i have programmed the ready made hex file to 8051 which is suppose to display a text. but making all the connections, when i give 5v to lcd's vcc pin and to 8051's vcc pin. LCD only shows the boxes ..ie no text.. So what should i do? is there anything more to do in order to make the 8051 to run the program ??

I've really tried google but it didnt help me..



Thnx in advance


Note. it is hex file in the attachment .. so remove .asmfrom the last
 

Attachments

Last edited:

Nigel Goodwin

Super Moderator
Most Helpful Member
I don't see how google doesn't help?, there must be hundreds of LCD designs out there based on the old 8051's?.

However, just looking at the circuit, where's your contrast control?, without that been present and correctly adjusted it's unlikely to display anything, even if working correctly.
 

ericgibbs

Well-Known Member
Most Helpful Member
hi,
Is there a 'contrast' control pot on the LCD.?
 

Chippie

Member
Sorry to point this out guys....

when i give 5v to lcd's vcc pin and to 8051's vcc pin. LCD only shows the boxes ..ie no text..
So the lcd is displaying black rectangles instead of characters


Sounds like the code isnt set up correctly to send the characters to the display...but I'm no expert..

I cant read the file neither....:(
 
Last edited:

ericgibbs

Well-Known Member
Most Helpful Member

Nigel Goodwin

Super Moderator
Most Helpful Member
Sorry to point this out guys....
Nothing to be sorry about :D

So the lcd is displaying black rectangles instead of characters


Sounds like the code isnt set up correctly to send the characters to the display...but I'm no expert..
That's one reason, another (which is why we mentioned it) is that the contrast isn't correctly adjusted - as was obvious from his diagram.

The OP was rather vague - but if it's just a single line of squares it 'could' be the setting up, but if it's two lines of squares, it's almost certainly contrast issues.
 

Chippie

Member
Nothing to be sorry about :D



That's one reason, another (which is why we mentioned it) is that the contrast isn't correctly adjusted - as was obvious from his diagram.

The OP was rather vague - but if it's just a single line of squares it 'could' be the setting up, but if it's two lines of squares, it's almost certainly contrast issues.
I've never had this problem with contrast....I've found that the lcd displays I've worked with needed next to nothing on the contrast pin to work, hence my thoughts being around s/w....

but thanks for pointing out that it could still be a contrast setting... :D
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top