• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

Controller's displays failing to turn on

Status
Not open for further replies.

solarium

New Member
Hi folks!

I was trying to solve a problem with power supply of my controller (TORO DDC-4) when suddenly the displays turned off. Then I made some simple measurements with my digital multimeter, starting from an area which earlier then this last displays' issuealready seemed a bit burnt (between the orange SMD diodes ZD1 and D10).
In the diode test mode I read these values (leads in both directions):
ZD1: 1 - 850
D10: 650 - 1
D11: 647 - 1
The other orange diodes (to their left), some of which hidden by the upper display, have similar values then those of D10 and D11. The only with a higher value is the zener (ZD1). I don't know if this can be considered an anomaly.
The other bigger diodes (D9, D12 and D21) showed these values:
D9: 623 - 1
D12: 602 - 1
D21: 604 - 1
At a glance all would seem regular.

So I measured the voltage at diodes' poles:
ZD1: -2.24 (both poles)
D10: -2.10, 1.83 (cathode close to D11)
D11: 2.40, 1.82
D9: -1.84, -2.03
D21: -2.19 (anode, successive to the zener in the circuit), -1.75 (cathode)

It could sound a bit strange but when I measured the voltage at D21 cathode I heard a hissing noise. The same thing happened to the successive poles of the components after D21 cathode (Q21 base and C21 upper pole). To rule out apossible D21-Q21 issue I replaced both of them. Apropos of replacingcomponents, I even replaced all the other transistors. After this action, I haven't heard any hissing noise anymore (maybe the new components are more efficient). Within the replaced transistors there was Q4, at whose collector there was no voltage. With the new one there is no voltage as well (perhaps this could depend on the malfunction of the central unit).

Probably, a short circuit or an overvoltage has damaged this PCB. I'm quite sure that this problem comes from the relay: I measured 12V arriving there after AC entry and a short circuit in the relay or its malfunction could have sent these 12V throughout the circuit, thus damaging the components which cannot resist to that voltage.
And I'm afraid that within these components there's the central unit.

Now, to rule out various PCB components, I decided to replace the relay, the electrolytic capacitors, the internal lithium battery, 2 resistors (over than the above mentioned transistors).
Original components are still the varistor (already checked), the keys, the SMD capacitors and resistors, the central unit (U1), the crystal (Y1), the inductors (L1 and L2), all the diodes (except for D21), the displays and a SOT23-5 (at least I guess: its code is C2ZD).

My attention is now focused on that SOT23-5 (U2 in the circuit, 2nd image, top center, focus on the last image). It should be a voltage regulator, am I wrong?
How can I measure its efficiency with a multimeter possibly without desoldering it?
Would it be possible to replace it with a non SMD transistor?
Measuring voltage I've read these values (from the left to the right): -2.11; 1.70; 0.85.

And finally, would it be possible to check the central unit (U1)? Should it be desoldered? It's a kind of little black dome outside with no readable code. Do you think it could be easily replaced?
I forgot to say that there are no electronic schematics available at the moment.







 

solarium

New Member
Thanks for your suggestion!
Continuity is OK but I noticed a couple of things that could be relevant.

First, getting power supply up (or connecting the 9V battery which doesn't make difference) in order to measure the voltage throughout the PCB, there's only 1 track with no voltage (but there is continuity in-between), namely the one going from MCU to the collector of the transistor Q4, marked 1p (the collector has no voltage too). Instead, base and emitter of that transistor have a voltage (respectively of -2.00 and -2.05V) similar to the nearby components.
Could it be normal or could it be a proof of the malfunction of the MCU which doesn't send electric signals to the Q4 transistor (perhaps, as I said, due to the overvoltage that could have damaged the central unit)?

Second, the C2ZD coded component only finds a Chinese site of an ALT81729C2TR with the right footprint. I can't access the pdf but a translation of the page indicates that this might be an LED-driver chip. A couple of days ago I tried to contact this company (via the e-mail address) to get the datasheet but no reply yet. At the same time I sent an e-mail to the e-mail addresses of the Shenzhen Anlutong Electronics Co., Ltd (ALT as abbreviation) through this page, but yet no reply.
A week ago I even asked directly to TORO COMPANY for the electronic schematics but yet no reply as well.
Apart from these inconveniences, using the diode test mode, I have found that putting the leads on the first and third pin (both directions) makes my tester beep. I haven't desoldered this IC yet even because I'm afraid to break it: I don't use any hot-air gun or hot air soldering station.
According to you, could that beep be normal?
 

mvs sarma

Well-Known Member
Hi, i have lately observed that there is a COB on the pcb. if that is meant for driving lcd,
perhaps we cant make it up.
please ensure that there is no short or low ohms across the derived power line to ground common. such short need not always blow the track.
try to reverse engineer a sch of the incoming power until you get the needed dc voltage to work with. it always helps trace things, in the absence of a regular factory schematic.

ps: please check 3rd photo, top left -to the left of RV1 -- the darkness. whether the track of 24Vac is in tact?
have they not used bridge rectifier to derive dc from 24VAC? as it appears half wave diodes seen,

Generally devices need , either 5V or 3.3V and you are getting less.
Try to check where the incoming power is converted to either of the needed supplies . Most cases of equipment fail at input power supply derivation.
 
Last edited:

solarium

New Member
As I am getting less voltage than needed, I have made some measurements starting from the 24VAC entry.
It seems that nearly 28V are coming to the PCB. Then the first component along the same phase wire's track is the reset key: zero volt. After, the varistor RV1: about 28V on the pin of the same track, zero volt the other one.
The next pin is of the relay (first pin on top right of the relay's square RLY1 in the photo): 28 V as well. But then the other relay's pins have no voltage (alternating and continued with no difference). Why this?
I was thinking that the relay I replaced is simply inappropriate (see the photo). The previous one was white (see the third photo at the beginning with values).
Could it be the cause of the voltage's absence?
As far as the dc voltage is concerned, I was not able to measure dc voltage throughout the whole PCB. This can happen only when I connect the 9V battery. There is no bridge rectifier, only diodes. And there must be something wrong with the dc derivation from 24VAC. Perhaps this could be even related to the relay's problem.


 

solarium

New Member
So it seems that there must be a diode rectifier. Apart from the 3 orange diodes in the center (ZD1, D10 and D11), the other ones under the superior display and another one near the lithium battery (all small and orange), there are 3 bigger diodes: D9, D12 and D21.
D9 anode does not receive any current from the inductor L1, nor any current comes from the relay to L1. D9 cathode is then connected to C7 capacitor (positive pole) but no voltage in-between. Before the negative pole of that capacitor there is no voltage as well. That track brings to the varistor at the beginning and again there is no voltage (instead, the opposite track, passing for the varistor and coming from the phase track of 24VAC, has 28 volts)
28 volts arrive to the first pin of the relay. Is it normal that the other relay's pins have no voltage? Could it be a problem of tracks in the relay's area?
I have been careful to ensure the contact between the relay's pins and the PCB. But should I remake tracks and holes of the relay's square?

D12 diode is located between the two poles of the 9V battery input (cathode near positive battery pin, anode near negative battery pin). The diode test mode shows normal values, as well as for D9. I guess it is not the key diode for the whole problem.

The last diode is the D21. Before its anode there is the zener (ZD1), after its cathode there is the transistor Q21 and a capacitor (C11). A couple of weeks ago measuring voltage on D21 cathode, I heard a hissing noise. The same happened on Q21 base and on the nearest pole of C11 capacitor.
Because of this, I decided to replace D21, Q21 and the other SMD transistors of the area with a 1N4007-B diode, a few NPN transistors marked BC337-40 and a couple of PNP transistors marked BC327-40. The particularity is that the non-SMD transistors (both NPN and PNP) have base and collector inverted with reference to the SMD transistors (marked 1P and 2F which should be respectively NPN and PNP). So I took this into consideration when installing them.
The result was that the hissing noise completely disappeared but the problem regarding incoming power management still remains.

Should I even replace the zener? It is not getting any current, as well as the nearby diodes (including the D21). I guess nothing would change if I replaced that component. Instead, could the problem be traced at the beginning, namely from the incoming power to the relay and the nearby components which, at the moment, have no voltage?
 

mvs sarma

Well-Known Member
Can you take pain to spare time to take photos under Sunlight , if possible with LCD plugged out VERY CAREFULLY< They would help trace out a possible sch and then our life would be easy to try servicing it.

Incidentally, is there a crystal around the glued controller?
if so you might use a capacitor (1000pF) blocked ac measurements on each limb of crystal or any resonator for trace of clock

I fear whether the working device underwent suffered surge (or spike of high voltage) that might have crippled it.

PS:
Perhaps the controller works from one or two 9V dc in the absence of 24V AC from transformer secondary.

you might have the manual of the device. how ever it attached
 

Attachments

Last edited:

solarium

New Member
OK, I have taken some photos with my bad camera, not so smart as the phone which has it installed. It is not able to manage the light very well...
Because of this I have decided to shoot small parts of the front side, hoping that everything is enough clear.
The other side has the LCDs to desolder which takes some time. If it is necessary for my purpose, I will remove them and take a photo to the components under them (4 small orange diodes, 2 capacitors and a resistor).

Actually, there is a crystal (Y1) on the opposite side of the glued controller and it is marked "S243". What does it mean?
Measuring hertz of this component with a function of my multimeter (square wave generator), I can report two values (because I inverted the leads): 155 and 435. Perhaps they are not indicative at all.
You suggested to use a capacitor of 1000pF but I have one of 33nF. Would it be OK? And then, what should I do? Soldering it to the crystal's limbs or what else?

I have nearly forgotten to say that I checked the diodes again (using the test diode mode). All in good shape, except for the zener (ZD1), at least I guess. Both directions show always 1 on the multimeter. Is that faulty? If so, because there is no readable code outside, what is the simplest way (using just a multimeter) to determine the correct diode to buy?

I know that the controller should work with only the 9V battery and the initial problem was only with the 24VAC (necessary to let the sprinklers start off). But then a short or an overvoltage crippled the controller (both 9V DC and 24V AC). Really, it is not so easy to trace the origin of the problem. It could be related to damaged tracks where should pass an amount of current instead of no or very few current. If it is something like that, I could even replace all the components but I would not solve anything. Slowly, I hope at least to rule out the various components (as the cause of the problem) just to determine whether the COB is the responsible of this situation.









 

mvs sarma

Well-Known Member
good effort ,
the Y1 crystal could be 32.768KHz used in clocks.
most battery operated analog clocks and digital timer clock chips have same. if you have any scrap clock you can salvage one and carefully replace the item. Perhaps the microcontroller might also be working with same or an internal clock.
 

Attachments

Last edited:

mvs sarma

Well-Known Member
please check whether you could access a working unit just for comparing the device and take measurements.
 

solarium

New Member
Continuity check done! My tester beeps, so it is ok. Actually, I scratched a bit the green layer to uncover the track just to check for continuity after the 9V battery input.
Unfortunately I have no scrap or new clock available at the moment but I can ask to an electronics shop. I had a look on the internet but I did not find any "S243" crystal. Perhaps, if I report to the shop's owner that the crystal could be 32.768 KHz, something might be found, even if with a different code.
Otherwise, I could make some measurements on it. I would need an oscilloscope, a frequency counter (often in a digital multimeter) or a simple crystal checker. I even could buy one of them, obviously the cheapest within them. The electronics shop where I usually go might have them available and at reasonable price. Is it worth?

Just a little clarification concerning the pin of the relay where I measured nearly 28V. If you take as a point of reference the image below, the relay's pin is the number 8, the one on top left of the reversed relay (reversed to show its footprint). The other pins have no voltage instead. If this is not normal, could it be due to the different footprint? The 6V original relay had the same values on its upper side as the new one. See the other image. Unfortunately, the original relay does not have its footprint marked on it and there is no datasheet available as the producer now sells a very similar relay but with a different code. When the voltage is only in the pin n. 8, what does this technically mean in terms of relay's activity? I am afraid that something bad (like a short circuit) happened in that pin (and then in that via).


 

mvs sarma

Well-Known Member
I suppose the DSY2Y-s-212L was a 12V relay. How come you are trying a 6V relay? Is it that original relay itself was 6V and the one i saw earlier was a replacement?

what ever, the footprint on pcb was meant for different type of relays.
hence duplication of the contact pins.
any 12V relay wold work well assuming that relay operating voltages is derived from 24V AC . the pinpout is universal for so called dpdt relay
I shall add comments later
 

solarium

New Member
I suppose the DSY2Y-s-212L was a 12V relay. How come you are trying a 6V relay? Is it that original relay itself was 6V and the one i saw earlier was a replacement?
Yes, the original relay was 6V but I was given a 12V relay as a replacement. So I decided to get back to a 6V relay just because the original was 6V. But things have not changed.
About the crystal, I was wondering whether it would be better to investigate more on incoming power management before the crystal because at the moment there is no current near the central unit (and the crystal that is right behind it on the opposite side of the PCB).
About the IC marked "C2ZD", I have found the datasheet of a series of voltage regulators (see this link: http://www.sii-ic.com/en/semicon/datasheets/power-management-ic/voltage-regulator-ldo/s-812c/). There is no final "D" but only the other 3 letters. If it is the same component as mine (despite that "D"), what kind of measurements could I make on it to test its efficiency?
 

mvs sarma

Well-Known Member
Solarium,
I think it better to drop the repairs , for
1 Chjp on Board(COB) microcontroller that cant be accessed.
2. lack of documentation.
I saw few comments that the firm amd its DDCs are junk 0-something like that
Sorry for my opinion
I really love the way you have seriously tried it.
 

solarium

New Member
I saw few comments that the firm amd its DDCs are junk 0-something like that
Yes, I definitely agree with you. Toro's facebook page confirms this: people complaining without getting convincing replies and sometimes without getting any reply. Perhaps the competitors are not so different. Nowadays the way of doing business of these big companies is just profit-oriented. Customer orientation is nothing more than a TV spot.
Anyway, I wanna thank you for your kindness. I have really appreciated your effort to help me in the repairs.
I hope the next time will be possible to successfully repair other electronic equipments.
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading
Top