• Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.

C18 has any one had this happen

Status
Not open for further replies.

be80be

Well-Known Member
The file in there it gust will not use it
Code:
Clean: Deleting intermediary and output files.
Clean: Done.
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F452 "main.c" -fo="main.o" -D__DEBUG -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
C:\Documents and Settings\burt\Desktop\first project\main.c:5:Warning [2066] type qualifier mismatch in assignment
Executing: "C:\MCC18\bin\mplink.exe" "..\..\..\..\MCC18\lkr\18f452.lkr" "main.o" /u_CRUNTIME /u_DEBUG /z__MPLAB_BUILD=1 /z__MPLAB_DEBUG=1 /m"gr1.map" /w /o"gr1.cof"
MPLINK 4.30.01, Linker
Copyright (c) 2009 Microchip Technology Inc.
Error - could not find file 'c018i.o'.
Errors    : 1

Link step failed.
----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\burt\Desktop\first project\gr1.mcp' failed.
Preprocessor symbol `__DEBUG' is defined.
Sat Mar 21 13:32:04 2009
 

AtomSoft

Well-Known Member
dude your path is toooooo long lol

If thats not the issue then try remaking the project like create a new one and add your files to it. Try to use a path with no spaces and not too long. and rebuild it
 
Last edited:

felis

New Member
This is Microchip classic. They introduce this bug regularly. The linker library path is not set; go to project settings, directories tab, then make a new entry for library path pointing to the lib/ in MCC18 tree.

I don't have MPLAB in front of me at the moment so I'm writing from memory. Should you have difficulties following that, let me know.
 

be80be

Well-Known Member
This is same place as C18 and I have added all files and it will not use them
Code:
Debug build of project `C:\first project\gr1.mcp' started.
Preprocessor symbol `__DEBUG' is defined.
Sat Mar 21 13:59:47 2009
----------------------------------------------------------------------
Clean: Deleting intermediary and output files.
Clean: Deleted file "C:\first project\gr1.mcs".
Clean: Done.
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F452 "main.c" -fo="main.o" -D__DEBUG -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
C:\first project\main.c:5:Warning [2066] type qualifier mismatch in assignment
Executing: "C:\MCC18\bin\mplink.exe" "..\MCC18\lkr\18f452.lkr" "main.o" /u_CRUNTIME /u_DEBUG /z__MPLAB_BUILD=1 /z__MPLAB_DEBUG=1 /o"gr1.cof" /M"gr1.map" /W
MPLINK 4.30.01, Linker
Copyright (c) 2009 Microchip Technology Inc.
Error - could not find file 'c018i.o'.
Errors    : 1

Link step failed.
 

binzer

Member
This is same place as C18 and I have added all files and it will not use them
I had the same problem, here is the solution from pommie.

From the C18 getting started guide,

EM-2 Linker error: “could not find file ‘c018i.o’”
Enter the proper directory path in Project>Build Options…>Project General tab. Set
the Library Path box to “C:\mcc18\lib”. c018i.o is the start-up library for MPLAB
C18. It sets up the stack, initializes variables, then jumps to main() in the application.

Mike.
Last edited by Pommie; 24th January 2009 at 02:19 AM.
 

be80be

Well-Known Member
There is no
Project General tab. Set
the Library Path box to “C:\mcc18\lib”.
in C 18 4.30 I found where that is now I'm getting this
Code:
Make: The target "C:\c18\main.o" is out of date.
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F1220 "main.c" -fo="main.o" -D__DEBUG -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
C:\c18\main.c:5:Warning [2066] type qualifier mismatch in assignment
Make: The target "C:\c18\gr1.cof" is out of date.
Executing: "C:\MCC18\bin\mplink.exe" /l"C:\MCC18\lib" /k"C:\MCC18\lkr" "..\MCC18\lkr\18f452.lkr" "main.o" /u_CRUNTIME /u_DEBUG /z__MPLAB_BUILD=1 /z__MPLAB_DEBUG=1 /o"gr1.cof" /M"gr1.map" /W
MPLINK 4.30.01, Linker
Copyright (c) 2009 Microchip Technology Inc.
Error - processor types do not agree across all input files.
Errors    : 1

Link step failed.
 

be80be

Well-Known Member
I got it you got to add the whole ball of wax looks like they would work better
mplab 8.20 and c18 4.30
 

binzer

Member
I got it you got to add the whole ball of wax looks like they would work better
mplab 8.20 and c18 4.30
Yup, integrate C18 into Mplab, works good from the little I have done so far.

The other error looks like you have defined a processor twice and it's not the same one..

I keep getting bitten by the first one, not sure why..:eek:
Mike
 

be80be

Well-Known Member
o 18F1220 in MPLAB but you use a linker script for 18F452
I no that I change that Do you have 8.20 mplab and C18 4.30 the documentations for it doesn't mach the ide I got it to work I no I set the linker wrong on this computer but I had it set the same on the 1 I posted first on but I came down here to see if it would work see when i installed C18 it ask to set linker and the rest of it up so you don't have to add it didn't work
Code:
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F452 /i"C:\MCC18\h" "main.c" -fo="main.o" -D__DEBUG -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
C:\c18\main.c:5:Warning [2066] type qualifier mismatch in assignment
Executing: "C:\MCC18\bin\mplink.exe" /l"C:\MCC18\lib" /k"C:\MCC18\lkr" "..\MCC18\lkr\18f452.lkr" "main.o" /u_CRUNTIME /u_DEBUG /z__MPLAB_BUILD=1 /z__MPLAB_DEBUG=1 /o"gr1.cof" /M"gr1.map" /W
MPLINK 4.30.01, Linker
Copyright (c) 2009 Microchip Technology Inc.
Errors    : 0

MP2HEX 4.30.01, COFF to HEX File Converter
Copyright (c) 2009 Microchip Technology Inc.
Errors    : 0

Loaded C:\c18\gr1.cof.
----------------------------------------------------------------------
Debug build of project `C:\c18\gr1.mcp' succeeded.
Preprocessor symbol `__DEBUG' is defined.
Sat Mar 21 17:01:14 2009
----------------------------------------------------------------------
BUILD SUCCEEDED
 
Last edited:

felis

New Member
I no that I change that Do you have 8.20 mplab and C18 4.30 the documentations for it doesn't mach the ide I got it to work I no I set the linker wrong on this computer but I had it set the same on the 1 I posted first on but I came down here to see if it would work see when i installed C18 it ask to set linker and the rest of it up so you don't have to add it didn't work
What language is that?

BTW, the output you posted says that your code compiled fine.
 
Status
Not open for further replies.

Latest threads

EE World Online Articles

Loading

 
Top