1. Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.
    Dismiss Notice

PSPICE Libraries Help

Discussion in 'General Electronics Chat' started by Luay1469, Nov 12, 2007.

  1. Luay1469

    Luay1469 New Member

    Joined:
    Nov 12, 2007
    Messages:
    3
    Likes:
    0
    Hello,

    I have installed the PSPICE Student edition and I am having an error problem. When I open the Schematics I get " ERROR; There was no configured libraries or no libraries section, [PARTS LIBS], in the .INI file" It is true I couldn't find even a resistor. Please help on this I have a school project that I need to work on ASAP. Thank you.

    Luay
     
  2. Hardwire

    Hardwire New Member

    Joined:
    Aug 15, 2006
    Messages:
    48
    Likes:
    0
    It sounds like the file "nom.lib" is missing from your configuration files. Open up a schematic page or create a new one and go to <Pspice>/<Edit Simulation Profile>/<Configuration Files (tab)> and highlight "Library" in the pull-down list. If you don't see "nom.lib" listed in the window, then you need to add it with the "Browse" button and add it as global or to design. I think it should be found in the library folder of pspice, or just do a search for it.

    Pspice can be impossible to use sometimes. This is just the beginning of the problems you will have with it. If you get it to work, here is another piece of advice: when you place a GND symbol on the schematic, make sure it's name is "0" (the number zero) in its properties or nothing will work.

    If the "nom.lib" fix doesn't work, then just ask your professor, teaching assistant, or another student for some help getting Pspice to run. Hope this helps.

    P.S. What student version are you using? What version number?
     
    Last edited: Nov 12, 2007
  3. Luay1469

    Luay1469 New Member

    Joined:
    Nov 12, 2007
    Messages:
    3
    Likes:
    0
    PSPICE Help

    Dear Hardwire,
    Thank you for your response. I will have to ask you your help again; first, you are the only one around since I am now giving some seminars in the Middle East I am couple continents away from school at University of Michigan. I took this class for the convenience Until I get back home.
    I did work on PSPICE before but as they say when it rains it pours. I am working from Sedra Microelectronic book that already has the software but it didn't work with me so I downloaded the software from electro-tech-online Student Edition 9.1. I do have the 9.2 version but it seemed more complicated to me as I didn't do much with PSPice since4 years ago.
    I was able to do most of the steps you mentioned but I had a warning saying that "nom.slb" and "nom.plb" are not found. I was able to find a similar answer as yours (thank you once again) from the help, but I believe I could not figure out how to solve the problem. Any Ideas PLEASE?
    Thank you
    Luay
     
  4. dave

    Dave New Member

    Joined:
    Jan 12, 1997
    Messages:
    -
    Likes:
    0


     
  5. Hardwire

    Hardwire New Member

    Joined:
    Aug 15, 2006
    Messages:
    48
    Likes:
    0

    I don't have those files "nom.slb" or "nom.pld" in my version of Pspice. Sorry, but I don't know what they are for.

    Can you get Pspice to function without these files? Maybe you can uninstall 9.1 and try the 9.2 version. Can you contact the professor of the class for assistance?
     
  6. Luay1469

    Luay1469 New Member

    Joined:
    Nov 12, 2007
    Messages:
    3
    Likes:
    0
    PSPICE help

    Hello!
    Thank you Hardwire. I guess I will have no other options but to try. Although I am not sure this particular professor will help on such issues. He has a say figure it out yourself.... I will hwever uninstall and reinstall the software and see what will happen. Time difference is an another issue. Thanks.

    Luay
     
  7. johan1234

    johan1234 New Member

    Joined:
    Apr 14, 2009
    Messages:
    1
    Likes:
    0
    Known its a long time ago. Had the same problem, but fixed it :)

    In schematics, press analysis -> libary and include files. You'll see nom.lib there. I deleted it and that solved my problem. Migth become a problem later on, but this is now :)
     
  8. pspiceiskillingme

    pspiceiskillingme New Member

    Joined:
    Jan 5, 2011
    Messages:
    2
    Likes:
    0
    ok i tried all of these, nothing worked! i tried the steps Hardwire was talking about, couldnt find anything. also, johan1234, your way didnt work. i installed and uninstalled it like 500million times but to no avail. when i open the schematics, immediately the message viewer says 3 errors:
    1. library not found: marker.slb
    2. warning: markers not found due to error loading library
    3.ERROR; There was no configured libraries or no libraries section, [PARTS LIBS], in the .INI file

    i also tried to manually look for and add the libraries and i ended up creating a little piece of hell for myself. PLEASE HELP ME OUT!! i've been suffering sleepless nights over this and i cant take much more. Also my professor is the type that says to figure it out on ur own....

    Thank you.
     
  9. pspiceiskillingme

    pspiceiskillingme New Member

    Joined:
    Jan 5, 2011
    Messages:
    2
    Likes:
    0
    i use pspice student version 9.1 btw.
     
  10. Eng_Bandar

    Eng_Bandar New Member

    Joined:
    Sep 6, 2010
    Messages:
    7
    Likes:
    0
    Thank you so much. I had same problem and now with your post with very thing work very well. I have Orcad 16.3 Demo.
     
  11. Eng_Bandar

    Eng_Bandar New Member

    Joined:
    Sep 6, 2010
    Messages:
    7
    Likes:
    0
    Thank you so much. I had same problem and now with your post, every thing works very well. I have Orcad 16.3 Demo.
     
    Last edited: Apr 13, 2011
  12. joana

    joana New Member

    Joined:
    Apr 17, 2011
    Messages:
    1
    Likes:
    0
    Hi!
    I had the same problem Luay. I solved it by adding the libraries manually. I went to Options-Editor configuration-Library settings-Browse. Make sure that the file extension .slb is selected so that you are able to see the files once you look for them using Browse. I chose one by one, for example: C:\Program Files\OrCAD_Demo\PSpice\Library\eval and then click on Add*
    I couldn't add all of them (it said that for the student version you just can add up to 10 libraries). I just had to drop one of them (I chose the one named special).
    At the editor configuration I had the library path: "C:\Program Files\OrCAD_Demo\Capture\Library\PSpice" but I guess I should have the other libraries too, I do not know why they didn't appeared by default....

    Once that made I went to Draw-Get New Part and finally all the components where there :)
    I was able to make a circuit, I run the simulation and it worked perfectly ;D

    I hope it is useful for you!

    best wishes
     
  13. Blackdot

    Blackdot New Member

    Joined:
    Sep 18, 2011
    Messages:
    1
    Likes:
    0
    Hi, all the guys who met the library in PSpice is not found, please try this out! It worked fine with me!

    1.Open PSpice Schematics, then immediately you get a error: many libraries are not found.
    2.click "option" in the menu, then choose"Editor configuration"
    3.In the center of the pop-up window, you can see the library path"D://program files/Orcad_Demo...."
    4.OMG! I installed the whole PSpice in C://Program files/....
    5.Just simply change "D" into "C". finally you will be fine!

    I am a new one here, just wanna to help those who met the same problem. It made me sleepless. :)
     
  14. kinarfi

    kinarfi Well-Known Member

    Joined:
    Jul 7, 2009
    Messages:
    1,503
    Likes:
    30
    Location:
    P. G., Utah, United States of America
  15. ArpitChy

    ArpitChy New Member

    Joined:
    Sep 27, 2016
    Messages:
    1
    Likes:
    0
    thanks a lot blackdot. that was a good suggestion. :)
     

Share This Page